0

This question already has an answer here:

I'm facing a problem with QGIS and have no clue what I'm doing wrong here. I've tried everything I know of.

I have polygon layer in CRS 2180. I add another layer that should be overlapping perfectly - and it does.

When I simply drag the layer to QGIS it fits perfectly fine, but when I change that new layer CRS to 2180 (THE SAME CRS THAT IM WORKING WITH) it goes somewhere far far away. I don't get it. Both layers are in the same CRS and they don't fit but when they're in different CRS then they fit. What am I doing wrong here?

I need them to be in the same CRS because otherwise the clip function doesn't work and I want to clip these new layers to only fit my original layer.

marked as duplicate by underdark qgis Jan 20 at 20:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • If you, instead of changing the CRS of the new layer, do right click on it, Export, Save Features As, and assign the CRS EPSG:2180 in the Save Vector Layer as dialog, the new layer created fits OK with the first one? – Gabriel De Luca Jan 19 at 21:51
  • Welcome to GIS SE. As a new user, please take the Tour. This question is one of our more frequent recurring topics -- There is a difference between changing a coordinate reference and projecting to that reference. Changing CRS actually corrupts the target, which is why project-on-the-fly ceases to operate. You need to project the layer – Vince Jan 19 at 22:20
  • Hi Adam - we don't have quite enough detail to be sure, but from what is in your question I think you've misunderstood the way that QGIS handles projections. To change the projection you don't change the setting in layer properties - you need to use 'save as' (as indicated in other answers including the one underdark links to). The projection setting in layer properties is designed to enable us to instruct QGIS as to what projection the data is already in (perhaps if QGIS has set this incorrectly). – Rostranimin Jan 21 at 9:53
1

Sounds like you are using wrong CRS when importing new layer. If you go to Settings > Options > CRS you can set what CRS is used when importing layer:

enter image description here

If this setting does not import layer in desired CRS it means files already include information about CRS and you should use Gabriel De Luca´s suggestion to reproject it: Export > Save Features As, secect desired CRS.

Not the answer you're looking for? Browse other questions tagged or ask your own question.