1

I am having an issue with both ArcGIS Pro and QGIS - both applications fail to consistently initialise / operate as intended when they do start up.

I have recently been trying to get Python 3 to work in my preferred IDE (PyScripter). After searching through many different Google results I managed to completely decimate my Python installation. I can use ArcMap 10.6 and Python 2.7 applications perfectly. PyScripter still works and I can create Tools as needed, however, whenever there is something requiring Python 3, these applications will not work.

QGIS - I have QGIS 3.4 Madeira installed and it will not open at all - I have uninstalled and re-installed it multiple times. I have also deleted the folders created during the install and tried to clear out all mentions of QGIS in the registry. I am assuming it is a Python error, due to the fact when QGIS is loading and the splash screen is describing the modules being loaded, the failure occurs when the "Starting Python" text appears.

ArcGIS Pro - I have installed Pro 2.4 on my machine. The system will load, however when I try to add data or run any tool at all the application will close with no warning error / notification. It is a straight crash. Again, I have completely uninstalled and re-installed it and even tried a repair. Same result each time.

Is there a way to restore my Python installations as intended for use with QGIS and ArcGIS Pro?

I am running Windows 10 64-bit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.