0

I have one GeoServer 2.12.5 with a layer which CRS is set to EPSG:3857, and another GeoServer 2.14.2 where I want to cascade WMTS from the first one. But when I add this layer from cascaded source its native CRS is detected as EPSG:4326, not 3857. I even deleted 4326 gridset from tile options of original layer, but is didn't help. How to fix cascaded CRS?

Original layer group CRS-settings: Layer group CRS settings

Original layer group gridset settings: Layer group grid settings

In cascaded layer its CRS is detected as EPSG:4326 detected CRS

1

It's a known bug, if this is important to you please consider sponsoring the work.

  • Is there a workaround? Does this bug relate only to WMTS in 2.14.2? In 2.12.5 I have same issue with cascading WMS. Is cascading feature is bugged in every version and for each protocol? BTW out of pure curiosity, is TDD used for GeoServer development? – SS_Rebelious Jan 21 at 10:31
  • It hasn't been fixed so it will continue in all versions since 2.14.x onwards. I believe all the test servers used defined epsg:4326 so it went unnoticed. – Ian Turton Jan 21 at 10:53
  • There is no time estimation to close the bug in the ticket. How much time will it take and what price are we talking about? If fixing this bug will be sponsored which GeoServer versions will be fixed? Would it be possible to patch existing installations? – SS_Rebelious Jan 21 at 11:23
  • 1
    please continue this on the geoserver-user list – Ian Turton Jan 21 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.