2

I'm having some trouble using the Batch Processing to perform r.series, Could anyone explain what I'm doing wrong? I'm using QGIS 3.4.4.

Output Log:

Processing algorithm 1/1… Algorithm r.series starting… Input parameters: {'-n': False, 'GRASS_RASTER_FORMAT_META': 'XML', 'GRASS_RASTER_FORMAT_OPT': 'GTiff', 'GRASS_REGION_CELLSIZE_PARAMETER': 10.0, 'GRASS_REGION_PARAMETER': None, 'input': 'D:\LocalDataStore\Pre-Processing\DecloudedRasters\18NVM\Band_02\Declouded_RT_T18NVM_20151221T153112_B02.tif;D:\LocalDataStore\Pre-Processing\DecloudedRasters\18NVM\Band_02\Declouded_RT_T18NVM_20151224T153612_B02.tif', 'method': [2], 'output': , 'quantile': 'float', 'range': '-1,1e+08', 'weights': '1'}

g.region n=0.0 s=0.0 e=0.0 w=0.0 res=10.0 r.series method="median" quantile="float" weights="1" range="-1,1e+08" output=outputf220a810b6eb44f884953602e7378fcf --overwrite g.region raster=outputf220a810b6eb44f884953602e7378fcf r.out.gdal -t -m input="outputf220a810b6eb44f884953602e7378fcf" output="D:\TEST_3.tif" format="GTiff" createopt="GTiff" metaopt="XML" --overwrite Cleaning up temporary files... access: No such file or directory Traceback (most recent call last): File "C:/PROGRA~1/QGIS3~1.4/apps/qgis/./python/plugins\processing\algs\grass7\Grass7Algorithm.py", line 413, in processAlgorithm Grass7Utils.executeGrass(self.commands, feedback, self.outputCommands) File "C:/PROGRA~1/QGIS3~1.4/apps/qgis/./python/plugins\processing\algs\grass7\Grass7Utils.py", line 386, in executeGrass feedback.reportError(line.strip()) TypeError: reportError(self, error: str, fatalError: bool): not enough arguments

Batch execution completed in 1.62 seconds

closed as unclear what you're asking by ahmadhanb, Jochen Schwarze, whyzar, nmtoken, Andre Silva Jan 24 at 3:38

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • g.region n=0.0 s=0.0 e=0.0 w=0.0 res=10.0 is the problem. You are calculating the median for two raster and the algorithm don't know from wich define the region. quantile="float" is another strange log, a float between 0 and 1 is expected. – Gabriel De Luca Jan 21 at 15:45
  • 1
    But the problem is with the python algorithm in batch mode: with one layer doesn't work in batch mode, with many layers works fine in simple mode. I'm finding worse problems in batch mode. Some algorithms of QGIS 3.4.4 cannot even start the batch mode window due to python errors (i.e, IDW and TIN interpolations). In r.series tool the batch process can not be saved and reopened, which generates an error. I don't know if it's the same for Linux users. – Gabriel De Luca Jan 21 at 17:12