2

I am working in FME with TIFFs downloaded from sentinel-1 (SAR). These TIFFs display correctly in ArcMap but in FME is loses its spatial reference and a bound box calculation gives the number of pixels in the tiff from the upper left corner at 0,0.

I concluded that this is an issue with the flavour of TIFF, so I exported the tiff in ArcGIS to a new file. FME could read this fine. A bounding box output would appear in the right place.

As I'm trying to automate a workflow, a manual export in arcmap won't be good enough. I've tried using the Python Caller in FME with

def processFeature(feature):
    origraster = feature.getAttribute('path_windows')
    print "!!!!!!!!!!!!!!!!!!!!!!!!!!! RECREATING RASTER!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
    print origraster
    newraster = origraster.replace(".tiff", "_arcgis.img")
    print newraster
    arcpy.CopyRaster_management(arcpy.sa.Raster(origraster),newraster)
    feature.setAttribute("newraster", newraster)

    pass

This creates a new raster (I've tried .tif, this is another test of using ERDAS Imagine .img) but one with has the same problems as the original.

I've tried RasterToOtherFormat_conversion but have the same problem.

Is there a difference between the process in exporting from ArcMap and copying in arcpy? And if so how can I remove this?

This is the info given in FME data inspector of the Python produced .img enter image description here

And this is what it sees if the .img is produced by manually exporting in ArcMap enter image description here

3

I downloaded a file and gave it a try (finding the same results as you by default). However... if you set the Apply GCPs parameter:

enter image description here

...choosing an appropriate interpolation method, then the data appears in the correct spot and is tagged with the coordinate system:

enter image description here

My guess is that ArcGIS applies those values automatically, whereas FME doesn't do that by default. I don't know what interpolation method ArcGIS uses though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.