I've got a problem using QGIS. Always when I try to launch the programme with the desktop icon, nothing happens. I also checked the Task Manager and it doesn't show any process running regarding qGIS.

The target field shows this: "C:\Program Files\Quantum GIS Lisboa\bin\nircmd.exe" exec hide "C:\Program Files\Quantum GIS Lisboa\bin\qgis.bat"

I had Microsoft C++ 2008 already installed, so I launched the installer and selected to repair it. However, QGIS still isn't launching.

I'm using Vista 32-bit.

I've tried to launch it manually, but then I get an error message telling me, that qgis.bat couldn't be found. I don't have any .qgs files on my PC, so I can't test it.

I can't find qgis.bat in the bin folder. But there's a file there called 'qgis.bat.tmpl'.

  • Assuming you're using Windows, if you right-click the icon and select 'Properties', what is the value of the 'Target' field? Does that file exist?
    – yalestar
    Commented Aug 6, 2012 at 20:37
  • you are not using 64bit windows by any chance?
    – mapoholic
    Commented Aug 7, 2012 at 9:52
  • 1
    Have you tried to start the qgis.bat manually? If you start it in cmd box, you might be able to read error messages. What happens if you double-click a .qgs project file?
    – AndreJ
    Commented Aug 7, 2012 at 15:27
  • I'm afraid your Qgis installation is totally broken. Please uninstall and try again.
    – AndreJ
    Commented Aug 10, 2012 at 19:31

8 Answers 8


I had the same problem...I resolved it by doing the following: - Upon locating qgis.bat, right click and go to edit mode. - add PATH %systemroot%\system32; %systemroot%; %systemroot%\system32\wbem after @echo off - Save - Retry launching qGIS.

I don't know why, but think i had this problem due to some system .dll files that were already on my machine and may have conflicted with those belonging to qgis.

  • 1
    this works! good..
    – vinayan
    Commented Aug 30, 2012 at 3:40

Usually the reason for this is a missing Microsoft Visual C++ 2008 Redistributable Package (x86). Install and try again.

  • A crumb for those in need: At least for my win7 pro x64 box I had both x64 and x32 versions of Microsoft Visual C++ 2008 Redistributable Package installed (and fully updated) and still QGIS failed to start. Can now start it with "C:\Program Files (x86)\QGIS Valmiera\bin\nircmd.exe\qgis.bat", but still not sure why the default install program links don't work. (And I've installed it twice so far.) Thanks underdark! Commented Apr 6, 2014 at 5:06

(In conjunction with the answers above) Check for the existence of the file qgis.bat


My issues were as described above - something hadn't worked during installation (quite possibly a local problem in a business network environment) and this file didn't exist. Re-installation solved this, but it was still necessary to create a QGIS launch shortcut as described in various places: the shortcut target must be:

"C:\Program Files\QGIS Brighton\bin\nircmd.exe" exec hide "C:\Program Files\QGIS Brighton\bin\qgis.bat"

(This shows the default path to the files for QGIS Brighton - obviously the paths need to be updated for newer versions or an alternate file location)


This is a very late reply.

Try removing Python from your system if it is already installed. There can be a conflict between the existing python in your system and the python installed as a package with QGIS.

Worked for me.


My QGIS was working perfectly fine until suddenly it didn't. I don't know what happened, but something had destroyed my user profile and prevented QGIS from launching. All I needed to do was deleting my profile folder in


and restart QGIS afterwards.

Attention: If you want to try to save your plugins and saved user expressions, then backup the plugins and expression folder inside the python subfolder of your profile and copy it into the new and clean profile that you create.

Worked perfectly for me, unfortunately other user settings got lost.w


Regarding Rostranimin's answer, it brought some light to me about how to deal with this. In any case, I remained suspectful about nircmd being a virus or at least behaving as such.

All my shortcuts' targets had been modified (not knowing how) to what Rostranimin says:

C:\Program Files\QGIS X.XX\bin\nircmd.exe" exec hide "C:\Program Files\QGIS X.XX\bin\qgis.bat)

It seemed obvious to me that nircmd was hiding the true qgis.bat file (whose existence must certainly be checked), so I just deleted the first path and the "exec hide" words. Eventually the remaining target was:

C:\Program Files\QGIS X.XX\bin\qgis.bat

Might look quite obvious, but it solved the problem for me though I still don't know why nor how from one day to another the nircmd started to apply. Nircmd seems to be part of qgis project, am I right? Or did it creep into my installation files as a virus or something?



This is a less permanent solution.

Find the "C:\Program Files\QGIS 3.32.2\OSGeo4W.bat" and run it. This opens a command prompt

run qgis

This will open the software.

For context, I've installed the software, ran the repair, and windows does not recognize it as an lauchable application.


Try deleting sections from QGIS3.ini. I just had to delete [cache], then it worked fine. The rest of the profile was ok, and QGIS started like normal again.


Remove the following: [cache] size=@Variant(\0\0\0\x81\xff\xff\xff\xff\xa0\0\0\0)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.