How do I change this PATH (it says read-only and won't stick) or use the network installer to make this work correctly on Windows 10? All I want to do is use QGIS and Grass?

I've honestly been struggling with this for days, can someone answer a very simple question - does Grass work on QGIS 3.4.4 on Windows 10, and if so how do you install and configure it correctly?

Or can at least one person tell me that they've successfully tested this setup that I've described?

enter image description here

enter image description here

Here's another illustration (sorry about Trump!) which shows the issue, network installer thinks it is installing grass 7.4.4, but it's not because it writes 7.6.0 to the folders in OSGEO4W - how do I fix this? I used network installer express desktop install and had previously del everything associated with grass and QGIS...I think...

enter image description here


So I think I fixed this by running the advanced installer and downgrading grass to - now it works.

This might make sense to someone involved with the project and the intricacies of the OSGEO4W installer, but wow - someone should really fix the Desktop express install option in the network installer and/or fix QGIS to use the same grass version, maybe a warning or something - that was very confusing for someone not experienced with QGIS and I suspect will turn some new QGIS/GRASS users away. "Express install" implies that it's basic and that it will simply work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.