1

I'm attempting to add a weather map layer (a satellite image) to QGIS 3.4.4 using tiles from aerisweather.

The URL (with credentials) is

https://maps.aerisapi.com/OcY2Lrnvyk26SIjfqUluj_pz9Tq0uvH1iGKSwn7Q0Ae6yEflSDkdBQyrDJSkFn/flat-dk,water-depth,admin-cities-dk,satellite-infrared-color/{z}/{x}/{y}/current.png

enter image description here

I'm able to add the connection in XYZ tiles without any apparent error, but the result produces a blank preview and map.

Is there anything obvious here that I am doing wrong, or is this simply not viewable in QGIS?

  • You are missing your >client_id< +client_secret ie "http_s://maps[server].aerisapi.com/[client_id]_[client_key]/[type]/[zoom]/[x]/[y]/[offset].png" see aerisweather.com/support/docs/aeris-maps/map-access/map-tiles – Mapperz Jan 26 at 0:43
  • Thanks for the suggestion Mapperz. My client id and client key are included in the original string above. Is this just a syntax error of some kind? I'm using their map link builder to no avail: aerisweather.com/account/map-builder – Scott Stephens Jan 26 at 13:36
  • 1
    I got you key working when I used maps1,maps2,maps3,maps4 instead of just maps so looks like they have a subdomain of tile servers. – Mapperz Jan 26 at 16:52
  • Thanks again Mapperz --- I added a screen capture of my XYZ Connection dialog box ---- Do you see anything that I may be doing wrong here? Still wrestling with the blank results screen. – Scott Stephens Jan 27 at 0:32
  • Scott I believe that QGIS is not understanding the [Offset] part of the url but can get the png in like maps2.aerisapi.com/… – Mapperz Jan 27 at 5:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.