2

After uptdating Qgis to 3.4.4 the following expression doesn't working anymore:

"art" LIKE '%'  || attribute ( @atlas_feature , 'artere')  || '%'

We're using it in the printcomposer, specifically on an attribute table. It was used to display lines with art value containing the same value as the layer we're using to generate the atlas, which always has the column artere.

On previous version, it was working. Not anymore.

Did we do something wrong?

  • Welcome to GIS.SE. What was your previous QGis-version? And how exactly do you use this expression? – Erik Jan 28 at 12:12
  • Thanks My previous version was 3.2 I was using this expression in a print composer. We are using an atlas. The atlas is set up on a layer. This layer have a colum named "artere". the expression I posetd is used in the print composer on a attribute table. The objective is to display every line of this layer containing the same value as the "artere" in his "art" colum. A minor detail, the "art" colum of the attribute table can contain something like this : 01 02 05 When the composer map show the line '05', we want the attribute table to display every line containint '05' it "art" colum – CBATS Jan 28 at 12:20
  • After checking it out, seems attribute(@atlas_feature, 'field') doesn't return the field values. That's weird. Didn't test in 3.2, but I tried in 2.18 and the function returns the field values correctly. – Gabriel C. Jan 28 at 15:09
3

It seems like this was/is a bug, reported in the issue tracker, that is already solved and should get corrected in the next release:

Within the layout composer, the 'filter with' feature on attribute tables no longer works for with @... variables. I have tested this with @layout_name, @atlas_pagename, @atlas_featureid, @project_crs and @project_author variables but assume it doesn't work with any of them.

If it's critical, maybe revert to your last working version until it gets released?

  • So many thanks, even if unsolved at least I know we didn't do something wrong. It was a hell to set this up. Think we'll roll back to a previous version. I still got one question, what is the lastest qgis version where the 'filter with" feature on attribute tales still work ? – CBATS Jan 29 at 4:40
  • @CBATS This I have no idea unfortunately. – Gabriel C. Jan 29 at 12:26
  • Don't worry, we'll stick to previous working installed qgis version and wait... – CBATS Jan 29 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.