1

Right after uninstalling and re-installing QGIS 3.4.4-2 using OSGEO4W Installer trying to start QGIS 3.4.4 I encounter the following error message:

enter image description here

My C:\OSGeo4W64\bin\qgis-bin-g7.env looks like this:

PATH=C:\OSGEO4~1\apps\qgis\bin;C:\OSGEO4~1\apps\grass\grass-7.6.0\lib;C:\OSGEO4~1\apps\grass\grass-7.6.0\bin;C:\OSGEO4~1\apps\Python37;C:\OSGEO4~1\apps\Python37\Scripts;C:\OSGEO4~1\apps\qt5\bin;C:\OSGEO4~1\apps\Python27\Scripts;C:\OSGEO4~1\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32\WBem;C:\OSGEO4~1\apps\msys\bin
GDAL_DATA=C:\OSGEO4~1\share\gdal
GDAL_DRIVER_PATH=C:\OSGEO4~1\bin\gdalplugins
GDAL_FILENAME_IS_UTF8=YES
GEOTIFF_CSV=C:\OSGEO4~1\share\epsg_csv
GISBASE=C:\OSGEO4~1\apps\grass\grass-7.6.0
GRASS_PROJSHARE=C:\OSGEO4~1\share\proj
GRASS_PYTHON=C:\OSGEO4~1\bin\python.exe
JPEGMEM=1000000
OSGEO4W_ROOT=C:\OSGEO4~1
PROJ_LIB=C:\OSGEO4~1\share\proj
PYTHONHOME=C:\OSGEO4~1\apps\Python37
QGIS_PREFIX_PATH=C:/OSGEO4~1/apps/qgis
QT_PLUGIN_PATH=C:\OSGEO4~1\apps\qgis\qtplugins;C:\OSGEO4~1\apps\qt5\plugins
QT_RASTER_CLIP_LIMIT=4096
VSI_CACHE=TRUE
VSI_CACHE_SIZE=1000000
O4W_QT_PREFIX=C:/OSGEO4~1/apps/Qt5
O4W_QT_BINARIES=C:/OSGEO4~1/apps/Qt5/bin
O4W_QT_PLUGINS=C:/OSGEO4~1/apps/Qt5/plugins
O4W_QT_LIBRARIES=C:/OSGEO4~1/apps/Qt5/lib
O4W_QT_TRANSLATIONS=C:/OSGEO4~1/apps/Qt5/translations
O4W_QT_HEADERS=C:/OSGEO4~1/apps/Qt5/include

The first entry in the PATH variable points to the referred qgis_app.dll.

The error occurs no matter if I try to start the executable (qgis-bin-g7.exe) by double click or from the start menu or the related batchfile (qgis.bat or qgis-grass7.bat).

Even more confusing: I have installed both qgis-dev (3.5) and qgis (3.4.4). qgis-dev does start even if I double-click the executable (.exe) and qgis does NOT start (same error) when double-clicking the batchfiles as mentionend above. No way to make QGIS 3 start.

The *.env files and the batchfiles for qgis and qgis-dev look allmost the same.

What do I miss to make my QGIS 3 running again?!

  • You could tr running QGIS as admin? – Jason Jan 28 '19 at 20:44
  • tried, but same error :-( – Jochen Schwarze Jan 29 '19 at 8:14
  • Having the same exact problem with running QGIS 3.10.0. I installed it yesterday, ran fine, no problems, tried to run QGIS 3.10.0 today and I get the same exact error message. The first entry in my PATH variable also points to qgis_app.dll (C:\Program Files\QGIS 3.10\bin\qgis-bin.env). Tried running as Administrator, no go. Restarted PC, no go. Never happened to me before today. – Rayner Nov 6 '19 at 13:58
1

This error appears if you double click the qgis executable. Here is the error, in my case, if I try to access directly the executable: enter image description here

Try instead to start QGIS double clicking the corresponding batch file (in my case: qgis-dev-g7.4.0.bat, like bellow) and everything will be ok.

enter image description here

  • Good hint, but some objections: I have installed both qgis-dev (3.5) and qgis (3.4.4). qgis-dev starts even if I double-click the executable (.exe) and qgis does NOT start (same error) when double-clicking the qgis-grass7.bat (or qgis.bat, respectively). I'll update my question accordingly. – Jochen Schwarze Jan 29 '19 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.