0

Something a lot like this happens every time I open something up in Q-GIS, regardless of the file type, location, or even the projection: they are all too wide.

Note: I am using the WGS-84 "reference" system, which the program has carried by default, but have tried over a fifty-dozen different, other projections: some centered, some regional, some worldwide. But none of them happen to display properly on top of the application.

What may be causing this? I would like to be proportional, like-say Google Maps, any generic atlas, the available visualization tools, or ArcGIS would have it.

enter image description here

EDIT: a few people have referred me to the following link. However, besides the fact that it doesn't even address the question as intended, only the WGS and a few variations thereof even show up on the map-files that I have created: as soon as I switch the layer/overall CRS over to literally anything else, the whole editor's usage-made screen goes blank, and only re-appears to pop out once I flip it back. Maybe, something-that is (unrelated) though, I don't know?

To clarify, and respond to @user's questions:

enter image description here

enter image description here

enter image description here

  • @user2856 First of all, thanks for the quick response. I have done so, as requested. I do not understand what your sentence about the "coordinates of your data ... change the project CRS" means. Could you please add some meat on the bones, by clarifying this information, and then suggest a proposal and/or raise a valid solution? Thank you very much, again, for this help. – Anna Jan 30 at 3:04
  • 1
    Anna (Coordinate Reference System = CRS) qgistutorials.com/en/docs/working_with_projections.html – Mapperz Jan 30 at 3:07
  • 2
    Hello Anna. Your question, and replies to comments indicate you are new to GIS and trying to learn it with QGIS. Welcome to this fantastic world. I also had a look at your previous questions, which seem to be common for people starting their journey in GIS. – jberrio Jan 30 at 3:07
  • Thank you, @jberrio how nice-and indeed, that's right: very kind of you! – Anna Jan 30 at 3:08
  • Having a complete answer to your question requires two things: 1) a general understanding of GIS and map projections (which is a science, or area of knowledge), and then 2) how to manipulate them using QGIS. – jberrio Jan 30 at 3:09
4

What happened here is that your QGIS project is set to EPSG:4326. This causes France to look that squished. To change that, click the text "EPSG:4236" in the bottom right and choose EPSG:3857 (if you prefer Google's globally super distorted Web Mercator) or EPSG:32631 / EPSG:32630 if you want to use a proper, locally perfected projection for France (that also has measurements in meters).

If that does not work, your data is bad. I assume that you started to change your data's projection definition in the layer settings. Never do that unless you really know what you are doing. Set it back to the original setting (or just start a new QGIS project), then it should all work just fine.

  • I have never changed the project/file/layer's map-projection information, before. – Anna Jan 30 at 18:04
  • Your suggestions do not seem to fix the problem, everything is squashed-just like before. – Anna Jan 30 at 18:05
  • @Anna, it seems that you are not able to render to a CRS that is not EPSG:4326. The bugmenot123's answer is good. In Project > Properties > CRS search and select EPSG:3857 (yes, it deforms a lot, but mainly in the opposite direction, you should notice it easily). And make sure that in the bottom right corner of QGIS window, the Render option is ticked and the CRS to render is the selected. – Gabriel De Luca Jan 30 at 22:41
  • So, now-what's "the" selected? – Anna Jan 31 at 1:11
  • 1
    @Anna, yes. It is very likely that the native coordinates of the geometries do not correspond to the CRS assigned to the layer. Investigate how to consult the coordinates of a vertex of a geometry and tell us what vertex it is and what coordinates it has. Something like: this vertex, in my layer, has coordinates x = ........; y = ......... – Gabriel De Luca Jan 31 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.