1

I get an error message when I try to publish a hosted layer to portal using ArcMap. Portal and server are federated, I have specified a hosting server and I am an administrator. I have signed in and out of portal and even deleted and re-instated the portal connection in Administrator but I still can't publish. There are no logs on server or error code provided - the error is:

The hosted server behind the portal could not be accessed. Please check with your portal administrator or use another server for publishing

I recently updated the admin URL in ArcGIS server /sharing/rest and I can publish service definition files from the server - I just can't do it from ArcMap. I found a local cache in AppData\Local\ESRI\Local Caches\MapCacheV1 which has the old server name so this could be the problem. Can I just delete this cache file or is there another way to refresh it?

enter image description here

The server and portal logs do not reveal anything related to the attempt to publish (on the verbose setting).

3
  • It would probably be wise to undo the recent changes. These are the sort of things to do before registering a hosted server. Once registered, you'd have to wander into unsupported modifications to reestablish communication.
    – Vince
    Feb 1, 2019 at 13:49
  • I have unregistered the hosting server prior to making the change and had to because every map service I published contained the name of the machine instead of the alias. This meant that none of them worked unless I manually replaced the machine name. This problem arose because the cloud engineer changed the host name after installing Enterprise. Anyway I was able to rename the host server as described above and can now publish packages on the server without a problem it is just that my ArcMap cannot find the server....so I'm guessing it is a caching problem ….since it signs into portal fine.
    – wunderkind
    Feb 3, 2019 at 22:09
  • Tried deleting the cache files as described but it did not fix the problem. Also archived the App Esri data folders for Local and Roaming, deleted my portal connection and renamed the registry enter for Esri. ArcMap fires up without my standard settings but can connect to portal and I still get the same message. There are no entries in fiddler for the server or portal and my machine shows no traffic in fiddler either.
    – wunderkind
    Feb 4, 2019 at 2:38

2 Answers 2

1

Edit: By using the tool "Manage Portal Connections" you can define a connection to your own ArcGIS Portal. Maybe try to redefine the connection to it from there? Thanks to @wunderkind for the link: ArcMap Documentation.

My experience with ArcMap taught me that you are able to publish Feature Services through it that are not "hosted". It accesses your ArcGIS Online account instead of your ArcGIS Enterprise deployment. All of my hosted feature layers were published through ArcGIS Pro to my deployment (on AWS). If it must be declared "hosted" than maybe you can do it from ArcGIS Pro? Otherwise, try to publish to your ArcGIS Server instead of "My Hosted Services"(My Hosted Services is on ArcGIS Online instead of your deployment). Even if not Hosted, it will still appear in your content folder and you'll be able to access it from the Portal, just like a hosted service.

2
  • 1
    The documentation indicates you can publish to your own portal from ArcMap:enterprise.arcgis.com/en/portal/latest/use/… Additionally, we do not use ArcGIS Online because of data sovereignty issues since our data on ArcGIS Online would not be stored in country (Australia). I have not test ArcGIS Pro yet but need ArcMap to work since 90% of users are familiar with it.
    – wunderkind
    Feb 3, 2019 at 22:31
  • Thanks! I didn't realize a tool had to be used in order to communicate with the Enterprise Portal. Adding that to the answer.
    – Oren_C
    Feb 4, 2019 at 7:54
1

I re-installed ArcMap but it made no difference. The vendor suggested I use Fiddler to check the traffic to the server. After installing Fiddler 4 I was able to decrypt the https traffic to the server and found that the call to ArcGIS server was being block somehow. There was no error code, the request just terminated - the call was made but nothing happened. This led me to suspect that the problem was IIS and thankfully I found the problem. In IIS a re-direct had been set-up for traffic that made calls to http re-directing them to the https portal site. Not sure why this was in place but removing the re-direct fixed the problem! Thanks everyone for suggestions but without an error code this was a tough problem to track down. I can now publish hosted layers yay!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.