1

I exported a map from ArcGIS 10.5 as an Adobe Illustrator (AI) file (.ai). When I open the .ai file (I'm using AI CC 2019 23.0.1 on a separate Mac), my ArcGIS polygons (Fig. 1) are 'messed-up'. Specifically, polygons that originally contained cut-outs (i.e. 'holes') are now 'filled' (Fig. 2). Moreover, AI has created unneeded polygons for the cut-outs (Fig. 3), but these don't necessarily match the original cut-outs - sometimes one original cut-out is filled by a mosaic of AI polygons.

How can I export the map/polygons correctly (I DO NOT want to post-process the polygons in AI)!?

Example of a polygon layer in ArcGIS 10.5 Fig. 1. Example of a polygon layer in ArcGIS 10.5.

Polygon layer from Fig. 1 in AI Fig. 2. Polygon layer from Fig. 1 in AI. Almost all cut-outs have been filled and AI has created one big polygon.

Cut-out polygons Fig. 3. AI has created additional, but unneeded, polygons for the cut-outs.

  • 2
    Please include a picture that illustrates what a close up on an area of concern looks like in ArcMap and then the same area in Illustrator, along with the detaild steps you used to go from the former to the latter. – PolyGeo Feb 4 at 21:15
  • even if it shouldn't matter for vectorial export (PDF or AI), I find that increasing the DPI setting in the export window help to get better export (you can go really high, like 2000 DPI or more) without increasing the file size. I think Arcmap simplify the shape by removing node during export, and maybe in your case it create some invalid geometry (dont forget to lower again the DPI before exporting non vector map or it will take forever...) – J.R Feb 5 at 13:53
  • @J.R Thanks for your comment. My ArcGIS map also contains a raster layer. I've tried to export the map with different dpi settings (300, 400, 800, 1000, 2000) - all with the above result... – MaikS Feb 6 at 15:17
  • You may try to repair geometry or to explode (using multiparty to single part) your polygon, if that fail you may have a look at the advanced setting (it's an app called AdvancedArcMapSettings.exe, in my install it's located here : C:\Program Files (x86)\ArcGIS\Desktop10.3\Utilities) if I remember well there is a setting to set the max node limit for export that you can try to increase (I can't check as you need to have admin right to use this) – J.R Feb 6 at 15:55
  • @J.R I adopted all of your suggestions, but without any success and the problem remains. – MaikS Feb 9 at 15:36
1

As a workaround:

Export each feature layer as a separate .eps file (remove any fill from polygons before exporting). Open all .eps files in AI and combine into a single map (re-add polygon fill). Each feature layer has to be exported with some sort of reference, a frame, for example, to match them up perfectly in AI. Once all layers are combined, delete excess frames.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.