1

My laptop (Lenovo x1) usually crashes When I add legend to a map composer in QGIS (QGIS 3.2 BONN). Problem is that all layers in the project will be "auto-updated" to the legend and this will get my laptop "stuck". Why is this "auto-update" box is pre-defined and checked. Of course this is dependant on your project size..but is there anyway to prevent this? i.e How to code "un-checked" auto-update box from the start?

1

Open a new, empty project. Add print composition, style it to your needs and when adding the legend, uncheck that box. Save the composition as a template and then use that template, whenever you need to create a map.

Also, you should remove the compositions from your project after having created a map, since loading compositions upon opening the project anew can result in significantly longer loading times.

  • I think QGIS 3 no longer pre-loads compositions when opening a project. – MrXsquared Feb 5 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.