1

I use QGIS 3.4 with Python 3.7 and I have a warning message when importing Processing like this :

import processing
from processing.core.Processing import Processing

Here is the message :

Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated, and in 3.8 it will stop working

What is the new way to import it without getting this DeprecationWarning ?

  • there is no new way! That is a message from the library collections that is used by processing! Note: I can not reproduce it – Fran Raga Feb 13 at 11:10
1

It's a common issue in Python collections library. Many libraries have this warning and should be updated to work with Python 3.8.

Don't worry, QGIS "processing" library should be updated before using Python 3.8. Ignore it for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.