5

My QGIS 3.4 Madeira project is attached to a PostGIS database (Azure) and looks good. It contains two layers, one with points and one with polylines. Each item in the Pointz layer has about ten attributes. When I use the standard Offline Editing plugin, it slides the attribute data over one column and ads an "fid" column - in the pointz layer only. The data is all there but in the wrong column.

How do I stop this or is this a bug in the Offline Editing pulgin?

This is how the attribute columns are supposed to be - enter image description here

This is what happens when I use the Offline Editing Plug-in.

enter image description here

UPDATE

I tried to add the fid attribute column as described below just to see what would happen. It created the fid_1 column as predicted. It must be something in the creation of the offline file that the mapping gets scrambled but how does it figure out how to unscramble them when Offline Editing Synchronizes? I have done this on two different databases now and it is the same.

enter image description here

UPDATE -

I have created a much smaller shapefile from scratch with exactly the same attributes and it works correctly. It may be a size issue? I do not know what is happening exactly. Does anyone have an Idea on how to troubleshoot? I do not think there is anything wrong with my shapefile. When I look at the attribute table it looks OK.

  • Which version of qgis? – ndawson Feb 7 at 21:44
  • 1
    Is the column real? ArcGIS also adds a FID field, but it isn't actually present, and if you were to create a field named "FID", it would be virtually renamed "FID_1" – Vince Feb 8 at 0:36
  • I will export it and see if the FID stays. Thanks – Cary H Feb 11 at 17:19
  • It is a "real" attribute in that I can sort by it and read it with code but when I go back into "Synchronize" or Online it goes away and the attributes go back to the correct spot. In offline mode the data is still shifting "one column to the left" and the left most column is gone. – Cary H Feb 13 at 22:02
  • 1
    Did you try to switch the offline editing file type from gpkg to spatialite? – Matthias Kuhn Feb 17 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.