I have collected census data for a county in Pennsylvania. Data varies from 1999-2010. For my data before 2010, a significant number of blocks do not match up (image below) when I join the data (based on GEOID).

I have joined to 1990, 2000 and 2010 census block groups. There are roughly the same number of block groups, but the GEOID's are always off for maybe 30% of the block groups.enter image description here

I feel like i'm missing something here... Anyone had trouble with this before?

So I'm offering a bounty now. Basically I just need to be able to join this data with the shapefile block groups from any year... But my guess is that they would best align with 2000.

  • 1
    Typically the census released crosswalk files of the changes, but in a quick search I was not able to find any for blocks. This website has them for larger geographies.
    – Andy W
    Aug 9, 2012 at 12:33
  • True, but I tried to join my data to past census block group shapefiles as well, and the result is the same, albeit in a slightly different way.... If there were changes between say 2000 and 2010, wouldn't my 2000 data still match up with 2000 shapefiles? It doesn't though...
    – Thad
    Aug 9, 2012 at 12:47
  • I'm not quite sure what your saying. If your 2000 census data does not match up to 2000 census geographies then you have problems with GEOID's in one of your data files, not with the geography (or changes in the geography). This could be anything, such as you are mistaken as to what the files are, or some errors in the data occurred somewhere. You haven't given enough information to really help besides point to the crosswalk files.
    – Andy W
    Aug 9, 2012 at 13:35
  • Ok. This is the meta data included with the data download... P052 HOUSEHOLD INCOME IN 1999 [17] Universe: Households NOTE: Data based on a sample except in P3, P4, H3, and H4. For information on confidentiality protection, sampling error, nonsampling error, definitions, and count corrections see factfinder.census.gov/home/en/datanotes/expsf3.htm.
    – Thad
    Aug 9, 2012 at 13:41
  • 1
    In case it's useful, here are links to the Census Block Relationship files: 2000 - census.gov/geo/www/relate/rel_blk.html 2010 - census.gov/geo/www/2010census/rel_blk.html
    – neuhausr
    Aug 9, 2012 at 14:08

1 Answer 1


I would check that you have downloaded the correct census files. I've spent many wasted days trying to figure out why I could not make an obvious join, only to discover that 2010 census files per state and per county sometimes have different codes. (I know this sounds strange but it is true).

Secondly, in the pre-2010 census, you should check how the LOCRECGNO number is constructed. There is a 6 digit code in there, and ArcGIS removes the prefix 00. So 004349 is 4349 Sometimes you need to pad the column of numbers so that the string is 6 characters long. This is only true when you try to construct the LOCRECGNO number from it's constituent parts. Again, it is an incredibly basic step that should not be necessary but I have also found this problem very hard to spot as some joins work (and others do not).

I found this site had a useful description of census fields. I joined all blockgroups in the US to the tabular data using census data from here and here.

  • Good advice. I am joining based on GEOID (which i assume is equal to LOCRECGNO). The numbers all have the same digits, but about half are off - and randomly, for each join I have tried using 2010, 2000, and 1990 shapefiles...
    – Thad
    Aug 14, 2012 at 18:09
  • I'm working from memory here, but I don't believe the GEOID had the same 4/6 character issue as the entire GEOID is included if you grab the correct shapefile.
    – djq
    Aug 14, 2012 at 18:28
  • Yeah they vary in length, but you can cut them down to match. I've done this successfully with 2010 data. My problem is only with census data prior to 2010. I must use 2000 data as 2010 data for many variables has yet to be released at the block group level.
    – Thad
    Aug 14, 2012 at 18:33
  • 1
    Just solved it. I knew I was missing something... You were right, arc was deleting those zeros and I had to *100 to get them back in.
    – Thad
    Aug 16, 2012 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.