0

When i open geonetwork "map", I want to see 'Canada' by default instead of other locations of the world. I changed the bounding box within an xml file located at /usr/local/tomcat8/webapps/geonetwork/WEB-INF/data/data/resources I am not seeing the change in the map extent.

can anyone suggest whats wrong here?

  • Using GeoServer? > geonetwork-opensource.org/manuals/2.10.4/eng/users/… [Geographic bounding box] – Mapperz Feb 11 at 20:00
  • No using geonetwork I have to make change in the xml file so that default map is focused on canada when I first load the map. I need to make change in the geonetwork java code built – yask Feb 12 at 13:29
1

You need to change the file config-viewer.xml. Usually this file is stored in the browser's local storage and it is not reloaded every time you access the webpage. Try to use an incognito window or to clear the storage after changing it.

0

You can use the bounding box settings in Admin Console --> Settings --> User interface tab.

  • I'm assuming you are referring to the Viewer Map Configuration? When I set these and save settings, nothing happens, so what is it you are suggesting? – Hornbydd Aug 13 at 10:52
  • 1
    Ok so things to check. If your Map projection is ESPG:3857. You can see this in the section above the Viewer Map Configuration. Then you need to set the coordinates to match the projection. For example on my setup. MinX =1830000 , MinY =-4140000, MaxX =3660000, MaxY =-2520000. Also make sure that the Layer objects in JSON is defined to something like this: {"type":"osm"}. I also went on to change the extent of the Search Map and Editor Maps. – Gerhard Brits Aug 15 at 6:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.