0

I'm having an issue with an annotation feature in ArcGIS desktop 10.5 where the character spacing is not being applied to the last word in multi-word features (see "ocean" in Pacific Ocean below) when exported to pdf (displays fine in layout view). Other multi-word features don't have this issue. Only features where character spacing <> 0. Any ideas on troubleshooting this issue?

enter image description here

  • What were the precise steps used to create that annotation feature? – PolyGeo Feb 12 '19 at 20:13
  • That is truly odd, but I think I have seen it before, the geometry is correctly encompassing what the length would be if it were placed properly; but first, there are many types of annotation : grapics (edit with draw toolbar), annotation and feature linked annotation, which type is this? Is this text straight or curved? What does it look like exported to PDF (it could just be a display problem)? Can you include a screen shot of the formatted text tab of the symbol editor? Can you break the text into two words or copy/paste and remove OCEAN from the first and PACIFIC from the 2nd? – Michael Stimson Feb 13 '19 at 0:40
  • I ended up setting character spacing to zero and adding spaces in the text string (e.g. "P A C I F I C"). Total workaround, but I needed to move on. – alaybourn Mar 13 '19 at 17:19
0

I had the same problem working with feature class annotation in ArcGIS Desktop 10.5. I have found that by using the context menu from the "edit annotation tool", you can convert the annotation to multiple parts. The object of this excercise is simply split a text string into single words. Once the annotation is converted to parts, it seems to maintain character spacing when the file is exported to PDF.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.