2

I have a shapefile loaded from delimited text with exact Northings and Eastings in the Romanian CRS (ESPG:3844). The layer CRS is correctly defined.

Meanwhile, my project CRS is WGS84 (ESPG 4329). OTF is enabled. The point plots on the wrong side of the road.

When I click on info for the layer and check derived location. The error is in the order of 10 or 15 meters.

If I do the conversion on the ESPG website I get the correct location (I know where the physical point is on the earth) and it matches. https://epsg.io/3844

What am I doing wrong? Why does the ESPG website give a different answer to QGIS? How can I get it to agree with the ESPG result and therefore plot correctly? I can't share the coordinates

QGIS version: 2.18.9

3

On the page you gave reference to we can the following definition of EPSG:3844 in WKT

PROJCS["Pulkovo 1942(58) / Stereo70",
    GEOGCS["Pulkovo 1942(58)",
        DATUM["Pulkovo_1942_58",
            SPHEROID["Krassowsky 1940",6378245,298.3,
                AUTHORITY["EPSG","7024"]],
            TOWGS84[33.4,-146.6,-76.3,-0.359,-0.053,0.844,-0.84],
            AUTHORITY["EPSG","6179"]],
        PRIMEM["Greenwich",0,
            AUTHORITY["EPSG","8901"]],
        UNIT["degree",0.0174532925199433,
            AUTHORITY["EPSG","9122"]],
        AUTHORITY["EPSG","4179"]],
    PROJECTION["Oblique_Stereographic"],
    PARAMETER["latitude_of_origin",46],
    PARAMETER["central_meridian",25],
    PARAMETER["scale_factor",0.99975],
    PARAMETER["false_easting",500000],
    PARAMETER["false_northing",500000],
    UNIT["metre",1,
        AUTHORITY["EPSG","9001"]],
    AUTHORITY["EPSG","3844"]]

Pay attention to the string TOWGS84[33.4,-146.6,-76.3,-0.359,-0.053,0.844,-0.84] This is those 7 coefficients of Helmert transformation used to define Pulkovo_1942_58 datum. In QGIS the same EPSG:3844 is defined in proj4 as follows

+proj=sterea +lat_0=46 +lon_0=25 +k=0.99975 +x_0=500000 +y_0=500000 +ellps=krass +towgs84=2.329,-147.042,-92.08,0.309,-0.325,-0.497,5.69 +units=m +no_defs

As you can see in QGIS another Helmert coefficients are given. So try to define custom crs in Custom Coordinate Reference System dialog

 +proj=sterea +lat_0=46 +lon_0=25 +k=0.99975 +x_0=500000 +y_0=500000 +ellps=krass +towgs84=33.4,-146.6,-76.3,-0.359,-0.053,0.844,-0.84 +units=m +no_defs

enter image description here

  • Thank you I have fixed the coefficients and it works perfectly. – Octahedral Cube Feb 13 at 13:01
  • You are welcome! – Vadym Feb 13 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.