1

I've successfully loaded OS MasterMap Topography GZs files into my PostgreSQL (9.5) database, using OS Translator II plugin within QGIS (2.18.18).

But somewhere during the translation process the unique feature references (TOIDs) gets replaced with the ogc_fid ([PK] integer) which is an integer instead of the TOIDs in the GZs files. Here is a screenshot of data in PostgreSQL table:

enter image description here

Does anybody know how I can get the TOID into the PostGIS?

0

I found the solution. When using the OS translator plugin to import Ordnance Survey MasterMap Topography into PostgreSQL database you should deselect the option for "Import boundary features (Ignore FID)."

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.