1

For some reason my landsat imagery through QuickMapServices is not showing up. I set the CRS to Albers Equal Area NAD 5070. It does say "Getting Tiles", so I'm not sure if it just takes hours to load?

Any ideas on how to get the imagery to come up?

enter image description here

  • Are you behind a proxy ? In my case google come fine but osm need the proxy deactivated to load – J.R Apr 8 at 22:14
1

It shouldn't take hours for a basemap to load. It shouldn't even take more than a minute, and that's with a very slow internet connection. Loading time on my computer (with a mediocre internet connection and at least a 5 year old desktop) is less than a second.

In my experience, not all the basemaps listed in the quickmapservices plugin menu actually work. I don't think I've ever been able to load the landsat layer. Try a few different maps from different data providers. The maps from OSM, Google, Bing, Stamen, CartoDB and ESRI usually work for me. (Some of those are extra basemaps that you can get by installing the "contributed pack.")

enter image description here

Also try putting your project in WGS84 or WGS84/Web Mercator. The basemaps seem to load more quickly in their native CRS's, which is usually one of those two. (I haven't seen this documented anywhere, it's just based on my personal experience). Once you find a basemap that works you can change it back to the CRS you want.

Or, you can first load a local layer (eg, get a shapefile for the state/province/country/county/city where you'll be doing your mapping). Zoom to that layer, and test out different basemaps until you find one that works at that scale.

| improve this answer | |
2

In QGIS 3.14, setting the Project CRS to WGS84 resolved the issue.

| improve this answer | |
  • Welcome to GIS SE! As a new user please take the tour. A good answer should not only give a solution, but also the steps the user follow to get to the solution. Please edit your answer to include the steps needed for "setting the Project CRS to WGS84" – Midavalo Aug 13 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.