1

I've just installed QGIS 3.4.4. Each time I edit any layer, as soon as I select the vertex editor (single shapefile) I receive the 'unknown exception error'. The error then occurs with ANY edit in any layer. QGIS then crashes.

I have checked in ArcGIS and the shapefiles are clean. I have tried creating new (clean) projects with new (clean) shapefiles of just a simple two-node line but nothing fixes this error. Every shapefile I create or download is faced with the same issues.

I'm stuck - any suggestions?

closed as off-topic by xunilk, Andre Silva, ahmadhanb, underdark Feb 17 at 19:38

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – xunilk, ahmadhanb, underdark
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Did you have previous versions installed? How did you installed QGIS 3.4.4 (stand-alone or network installer)? – Gabriel De Luca Feb 16 at 4:08
  • No. I just did a standard install: download.osgeo.org/osgeo4w/osgeo4w-setup-x86_64.exe – Peter Feb 16 at 6:55
  • Crash report: Crash ID: 6db1b9d6d539af58f60b41cae447e495b7c96ff7 QgsPointLocator::~QgsPointLocator : QgsPointLocator::~QgsPointLocator : QgsSnappingUtils::clearAllLocators : QgsSnappingUtils::~QgsSnappingUtils : QgsVectorLayerProperties::`default constructor closure' : QObjectPrivate::deleteChildren : QWidget::~QWidget : CPLStringList::operator[] : main : BaseThreadInitThunk : RtlUserThreadStart : QGIS Info QGIS Version: 3.4.4-Madeira QGIS code revision: af723c4942 Compiled against Qt: 5.11.2 Running against Qt: 5.11.2 Compiled against GDAL: 2.4.0 Running against GDAL: 2.4.0 – Peter Feb 16 at 7:11
  • I can't reproduce it here with the same install. Try with a clean profile, deleting the %AppData%\QGIS folder. – Gabriel De Luca Feb 16 at 7:15
  • Thanks Gabriel! I had tried a clean install which didn't help. I have now tried a clean install using 3.0.0 and this has solved it. Thank's for your assistance! – Peter Feb 16 at 7:19

Browse other questions tagged or ask your own question.