2

I came across an issue where I can no longer run a select by attribute on a field (In my example it is "Students_7") in a shapefile that previously worked. Even when I build the query using the wizard (see screenshot) it does not return any results.

Select By Attribute Not Working

I tried making a new column in my shapefile, with the same datatype, and then used the field calculator to make my new field equal to Students_7. I then ran the same select by attribute query on this new field and it worked.

Does anyone know why the select by attribute function no longer works on my Students_7 field? The only thing I did today, which is when this change happened, is join some files together, I've since gone and made sure to remove all other joins, I can see that "Students_7" is an indexed field, but I'm not sure how or when this happened.

  • 1
    Have you tried deleting the index, may be it has become corrupt? Try that then add it back? – Hornbydd Feb 18 at 23:37
  • 1
    Has your index been build with the UNIQUE option? I can see that the values are not unique which may be confusing the index if it is expecting unique values. – Michael Stimson Feb 19 at 0:13
  • 1
    Thank you, it seems to have been a corrupt index issue. – The Silent Cartographer Feb 20 at 7:08
1

@Hornbydd suggested I look at the Index, and that seems to have been the root of the issue.

I went into ArcCatalog to see about re-building the index, and when I went to the file properties>Indexes it said the layer did not have an index, so I created a new one.

Then I went back into ArcGIS looked at my file's attribute table, and the asterisk over the Students_7 field disappeared and select by attribute now works, so I guess it did get corrupt or something.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.