4

Using QGIS version 3.4.4 when loading a NetCDF file out.nc which contains multiple variables on a fresh Ubuntu 18.04 install I encounter the following error:

CRITICAL Invalid Layer : Raster layer Provider is not valid (provider: gdal, URI: out.nc

The same file load correctly on another 18.04 Ubuntu environment with more package setup. Unfortunately I cannot find which package is making the difference. The libgdal package seems to be the same on both environments.

  • Same issue on QGIS 3.6.1 on Windows (using OSGEO4W distribution)! – gmas80 Apr 7 at 17:02
  • 1
    I had the same issue on 3.4 so upgraded to 3.6.1 to hopefully fix it, but still get the same error. Both installed with OSGEO4W. – BStone Apr 11 at 8:12
  • There is now a ticket for this issue: issues.qgis.org/issues/21783 – gmas80 Jun 1 at 21:12
  • Corresponding GitHub ticket: github.com/qgis/QGIS/issues/29598 – gmas80 Jun 1 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.