0

I am doing a GetCapabilites request on geoserver to get the bounding box of wms layer but in the response, i am only getting a bunch of EPSG projections but no layers? this is the request i am using:

http://localhost:8080/geoserver/wms?service=WMS&request=GetCapabilities&version=1.0.0

Also i have read the documentation of get capabilities https://docs.geoserver.org/latest/en/user/services/wms/reference.html#wms-getcap and they have mentioned a namespace parameter to bound the result of GetCapabilites request to a specific layer,what should be the value of this parameter ?

  • Is there a reason you are using version=1.0.0 instead of 1.1.1 or 1.3.0? Do you have anything like an isolated workspace in use? – EnE_ Feb 20 at 5:08
  • nope, I tried changing the value of version still no response – Gaurav Feb 20 at 5:12
  • i you have put everything in an isolated workspace you may need something like localhost:8080/geoserver/WORKSPACENAME/… – EnE_ Feb 20 at 5:14
  • to answer your question it may be something like WorkspaceName:LayerName – EnE_ Feb 20 at 5:19
  • This is a typical response from WMS Service demo.geo-solutions.it/geoserver/…. WMS 1.3.0 shows bounding boxes a bit better than earlier versions but 1.1.1 should work for you as well. GeoServers do not support WMS 1.0.0 but if you ask for it you are actually getting WMS 1.1.1 response back. You wrote you do not get layers in GetCapabilities; are you sure? Look at the end of the document. – user30184 Feb 20 at 8:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.