1

I want to add an attribute from a vector line layer to a vector point layer.

The vectorline is railwaynetwork. It has been divided into segments automatically. To process the data further I had to convert the lines into points. I wanted defined distances in between so I chose to use the plugin QChaninage. Now I got points in my defined distance. But in the attribute table there aren't any of the original attributes that where in the vectorlines table. How can I connect those attributes with my points?

I already tried to use tools from the toolbox (e.g Join attributes by location tool) but until now I could not solve it.

closed as too broad by ahmadhanb, MaryBeth, whyzar, Jochen Schwarze, xunilk Feb 20 at 18:22

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you tried the Join attributes by location tool since the points should lie exactly on the lines? – Joseph Feb 20 at 10:12
  • yes I tried that one but in the resulting table there hasn't been an added attribute to each point – Jule kle Feb 20 at 10:30
  • 1
    Based on the information you've provided, I don't see any reason why @Joseph's suggestion wouldn't work. Can you update your question with more information about what happened when you tried join attributes by location? Without more information there's no way to know what the issue is. – csk Feb 20 at 18:16
  • I edited my question. If its still not enough information please ask me again. – Jule kle Mar 5 at 12:16
  • I believe join attributes by location did not help because the information of the original vectorline is only saved in segment beginnings and endings, but not in between. – Jule kle Mar 5 at 12:19