2

In QGIS 3.4 I am trying to join 'UTM32 Ebenen file.csv' and 'VG250_GEM.shp' using columns "Column2" and "SDV_RS", respectively.

I am following the instructions found in QGIS Tutorials and Tips | Performing Table Joins. When I try to perform the join, the fields in the CSV file are NULL.

Do the two files have to have the same number of rows? Must all rows find a match in order for the Join to be successful?

Following the advice of @DPSSpatial, I have used the Refactor tool to change the data type (of the columns that I want to Join on) to integer.

5
  • 5
    They should be the same data type between both datasets, integers on joins is preferred, or small blocks of text. Feb 22, 2019 at 21:01
  • @DPSSpatial: thank you for that hint. I have used the refactor fields tool to change the dtype to integer for both files and I still have the same error Feb 23, 2019 at 14:51
  • 3
    The data in those two columns looks different - I see the SDV_RS column contains leading 0's, which likely got truncated when you converted to INT. The CSV doesn't seem to have those leading 0's at all. How many features do you expect should be matching if you join them? Feb 23, 2019 at 17:55
  • @DPSSpatial: thank you for taking the time to point out my carelessness. And thank you for humbling me. Feb 23, 2019 at 19:46
  • 3
    Oh no not carelessness - not meant to humble either - it's a data problem - just asking questions I would ask if you were a member of my team...! Feb 23, 2019 at 20:39

0