1

I am trying to join this data to this data (UTM32 Ebenen file = VG250_GEM.shp) using columns Column2 and SDV_RS, respectively. I am using QGIS 3.4

I am following the instructions found here . When I try to perform the join, the fields in the csv file are NULL. Following the advice of DPSSpatial, I have used the refactor tool to change the data type (of the columns that I want to Join on) to integer.

Do the two files have to have the same number of rows? Must all rows find a match in order for the Join to be successful?

6
  • 4
    They should be the same data type between both datasets, integers on joins is preferred, or small blocks of text. – DPSSpatial_BoycottingGISSE Feb 22 '19 at 21:01
  • @DPSSpatial: thank you for that hint. I have used the refactor fields tool to change the dtype to integer for both files and I still have the same error – Michael Perdue Feb 23 '19 at 14:51
  • 2
    The data in those two columns looks different - I see the SDV_RS column contains leading 0's, which likely got truncated when you converted to INT. The CSV doesn't seem to have those leading 0's at all. How many features do you expect should be matching if you join them? – DPSSpatial_BoycottingGISSE Feb 23 '19 at 17:55
  • @DPSSpatial: thank you for taking the time to point out my carelessness. And thank you for humbling me. – Michael Perdue Feb 23 '19 at 19:46
  • 1
    Oh no not carelessness - not meant to humble either - it's a data problem - just asking questions I would ask if you were a member of my team...! – DPSSpatial_BoycottingGISSE Feb 23 '19 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.