1

I have a body of users using an Eclipse RCP-based Java desktop app (32-bit JRE1.7, Windows 7) that uses GeoTools for world/screen projection handling.

This morning the app has started failing for just one user. It worked fine on Friday. Significantly, CRS is not finding the transform, so _degs2Metres takes a null value:

_worldCoords = CRS.decode("EPSG:3395");
final CoordinateReferenceSystem worldDegs = CRS.decode("EPSG:4326");
_degs2metres = CRS.findMathTransform(worldDegs, _worldCoords);

This happens for just one user, on a network of users with (apparently) identical PCs. He tried restarting his PC, but it didn't fix it.

He has prior versions of the app running back to Oct 2018, and all of them now fail in the same way. We also tried opening 10-year old datafiles, and they won't open. This makes it look like the problem is outside this app.

It really looks like something we're unaware of has changed with his PC config. He's not aware of anything changing over the weekend, nor are his IT support staff.

Has anybody encountered a class-path, or some MS Windows config change that has caused the CRS.findMathTransform() method to fail?

I believe GeoTools uses an H2 database to store the EPSG codes, so I guess his PC could have some other H2 database driver that is being used instead of the GeoTools one.

Any other suggestions?

1

GeoTools unpacks it's EPSG database in a temporary directory called /tmp/GeoTools on unix boxes. On windows it's called C:\Users\ian\AppData\Local\Temp\GeoTools (or whatever your user is called). It should contain Databases/HSQL/v8.6.0.1 the most likely problem is that the user has lost permissions to the folder, or something has corrupted the files, try deleting it and starting again.

It could be a driver mismatch, or just Windows being funny, try reinstalling from yesterday's backup?

  • 1
    Thanks for that @ian-turton . The onsite maintainers suspected there was a temporary folder that should be deleted, though they many not know about this specific folder. (oh, and thanks too for correcting the title typo). – ianmayo Feb 26 at 12:14
  • Yes, @ian-turton, I've just had confirmation that deleting the GeoTools folder fixed the issue. Thanks again for your support. – ianmayo Feb 27 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.