3

I am working with QGIS 3.4.4 Madeira (OSGeo4W) I have a Digital Elevation Model/Digital Terrain Model of a watershed with a EPSG:3006 - SWEREF99 TM - CRS (that is actually unsuitable for the DEM cause the DEM-Area is out of the boundaries of that CRS. That file was given to me by someone else, so I don't know why they used this crs) I wanted to reproject it to WGS84 UTM33N. I used the QGIS Raster->Projection->Reproject it returns the error ERROR 4: false: No such file or directory

that is the command (i replaced the file path wit ...)

{ 'DATA_TYPE' : 0, 'EXTRA' : False, 'INPUT' : 'C:/...file.tif', 'MULTITHREADING' : False, 'NODATA' : None, 'OPTIONS' : '', 'OUTPUT' : 'C:/.../file.tif', 'RESAMPLING' : 0, 'SOURCE_CRS' : None, 'TARGET_CRS' : QgsCoordinateReferenceSystem('EPSG:32633'), 'TARGET_EXTENT' : None, 'TARGET_EXTENT_CRS' : None, 'TARGET_RESOLUTION' : None }

GDAL command: gdalwarp -t_srs EPSG:32633 -r near -of GTiff false C:/Users/Tobias/Documents/Studienprojekt/DGM/Lockwitz_DGM.tif C:/.../file.tif GDAL command output: ERROR 4: false: No such file or directory

The file is there! I tried with the file loaded to QGIS; directly put in the file-path; save as temporary-file; save permanent Nothing works always this Error, I also tried with another DEM (ASTER-GLOBAL-DEM, and SRTM-DEM) but I always get this error. So is there something I am doing wrong or misunderstand regarding that function? Or has anybody experienced similar issues with that? (Just started using QGIS so excuse if I overlooked something)

3
  • Error seems to come from output output: ERROR 4: false: No such file or directory. Does the output directory certainly exist and do you have rights to create new files into it?
    – user30184
    Feb 25, 2019 at 12:03
  • I think the output is from the GDAL command output: which I would interpret just as the output of the command itself. But anyway QGIS should have access to that file path. I tried different paths and it's always the same. Other functions operate without any problem on that file path, even other gdal-functions work fine.
    – tobias_p
    Feb 25, 2019 at 15:56
  • Yes, you are right. Sorry for confusion. But I made a trial with my QGIS 3.4.4 and it does not produce that 'EXTRA' : false parameter.
    – user30184
    Feb 25, 2019 at 21:30

2 Answers 2

2

That was a bug in the algorithm, already reported (https://issues.qgis.org/issues/21159) and fixed (https://github.com/qgis/QGIS/pull/9094).

Upgrade to QGIS 3.4.5 (LTR) or 3.6.0 (current).

1

try it without the

false

The code tries to use it as the directory

2
  • I can't access the gdal-command line through the QGIS function-window. Is there any way to access the command prompt via QGIS? I installed QGIS 3.6, calling the reprojection-function there doesn't include the false in the command line, and it works. So as you said, the false is the problem.
    – tobias_p
    Feb 25, 2019 at 16:32
  • Extensions---> Python Console
    – Leo
    Feb 25, 2019 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.