1

I am working on my project in QGIS 2.18 through Graphical modeller and using some basic algorithms for polyline objects.

project_workflow

However, I do not understand why specification for Dissolve algorithm cannot be saved as a parameter in its window. Any ideas?

When I execute this model through Processing Toolbox it dramatically impacts my desired output. Looks like it simply does not remember my settings.


Example. I use "SLINIE" field as a Dissolving parameter.

Before

But after I click "OK" and open the window again I can not see that option.

After


Can you tell me please what I am missing?

Another solution such as

  • SAGA Line Dissolve works only with three parameters
  • With OGR Execute SQL I can execute the proper query but I do not know how to save properly the output as a shapefile.
2

The Unique ID fields setting uses the Table multiple field parameter as input. If you add this to your modeler, you can connect the setting to the parameter which will allow you to select your field(s) when you run your model:

Exampel model

  • 1
    dope...that is what I actually searched for...how did not I see 'Parameters'... Thank you so much! – Taras Feb 26 at 11:28
  • 1
    @Taras - Most welcome, glad it helped :) – Joseph Feb 26 at 11:30
  • 1
    @Taras - Thie link should be suitable for 2.18. If you want to see exactly which parameters are used in a tool (instead of adding each parameter and see if they can be selected from the GUI) then you could read the source file for the tool (e.g. C:/Program Files/QGIS 2.18/apps/qgis-ltr/python/plugins/processing/algs/qgis/dissolve.py) and search the defineCharacteristics() function. This includes which parameters are added. – Joseph Feb 27 at 13:12
  • 1
    @Taras - Most welcome! When I first started using models, I always had to do a trial and error to see which parameters can be used by which tool. Now I just quickly check the script itself which saves me a lot of hassle :) – Joseph Feb 27 at 13:23
  • 1
    Thank you for one more immense point based on your own experience – Taras Feb 27 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.