This is closely related to several other questions on this site: here, here, here etc. However, my issue is not resolved by following the answers provided.

I am using the Raster Terrain Analysis plugin in QGIS ver 2.14.3. I want to create a Slope layer based on SRTM imagery. I understand that confusion can arise because the lat-lon units are degrees, and the vertical units are in metres. I calculated the z-factor with the formula z = 1/(111320*cos(latitude*pi/180)) provided in this answer. Which gives 0.00000899928 (I'm using imagery which spans the equator so used latitude = 0).

SRTM Imagery

However, I get a layer of either 0 or 90. It is very similar to the question here. Re-saving the layer with WGS84 before using the plugin does not help.

Incorrect slope

I am able to produce a sensible looking Slope layer if I convert the CRS to World Mollweide, but I would like to know why it isn't working with CRS in degrees? What am I doing wrong?

1 Answer 1


This is a really common error. You need to choose a projected coordinate system to warp your raster layers before doing any slope calculations.

Since slope is determined by rise over run, If you elevation units are in metres and your distance units are in degree-decimals, even small changes in your elevations will easily calculate your slope at 90 degree inclinations.

Since your data is located at the equator, see if you can find where your region is along the Mercator system and warp your raster to an EPSG CRS that is appropriate for that area.

For more information: https://en.wikipedia.org/wiki/Map_projection

  • Thanks for the answer. Converting to UTM did the trick. I'm still not sure why I couldn't directly use the WGS84 layer with the correct z-factor though. I understand that the slope would be calculated at 90 degrees if there was confusion between decimal degrees and metres, but why was the z-factor not being incorporated?
    – EcologyTom
    Commented Feb 25, 2019 at 15:27
  • I've tried your approach a few times and while I do agree that it makes sense, I've never been able to get it to work well with z-factor conversion. My only suggestion if you still wanted to continue with it is to try adding more zeros. As you pointed out, a value of 90 suggests that the conversion is still too high. If it still doesn't work, it could be a bug worth reporting: qgis.org/en/site/getinvolved/development/bugreporting.html Commented Feb 25, 2019 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.