I updated QGIS to version 3.6 using OSGEO4w

When I try to run any GRASS script, I get the following error message :

Error message

This algorithm cannot be run :-( The specified GRASS 7 folder "C:\OSGEO4~1\bin\bin" does not contain a valid set of GRASS 7 modules. Please, go to the Processing settings dialog, and check that the GRASS 7 folder is correctly configured

It looks like the path doesn't exist, but I couldn't find a place to change it; it is not an option in the processing settings any more like in versions 2.x.

Is there a way to run those processing scripts in QGIS 3.6 and if so, how could I tweak the settings needed?

Edit : Here is what my processing options looks like

Processing parameters

  • Have you tried to use QGIS 3.4.5 (the new LTR), it works in this version. – ahmadhanb Feb 27 at 8:23
  • When I start GRASS first, then load QGIS, all is well. Otherwise, not. – Jim McLaughlin Mar 18 at 13:59

If I open QGIS with the shortcut "QGIS Desktop 3.6.0 with GRASS 7.6.0" everything works fine. If I open QGIS with the shortcut "QGIS Desktop 3.6.0" I get the same error as you

  • 4
    I wonder why GRASS is not the default option for starting with QGIS. – Mr. Che Sep 20 at 10:29

I had the same problem but I managed to solve it by renaming my grass folder from "grass76" to grass-7.6.0".


In respect to a part of your question

"It looks like the path doesn't exist, but I couldn't find a place to change it; it is not an option in the processing settings any more like in versions 2.x."

you can manage the path of the working GRASS folder through

Settings > Options > Processing > Providers > GRASS

Based on QGIS 3.0.3 version


where you can adjust the 'GRASS7 folder', just double click on it.

And by the way, GRASS works fine on my QGIS 3.0.3 version.

  • Which version is this screenshot from? I have attached mine, it looks like you have a few more options than I do! – Kantan Feb 27 at 9:08
  • 1
    QGIS 3.0.3 version – Taras Feb 27 at 9:09
  • You probably did not launch QGIS with GRASS in it – Taras Feb 27 at 9:12
  • The row for "GRASS7 folder" is missing in qgis 3.6 and 3.10 . – foobarbecue Nov 9 at 17:34
  • However, it is stable for LTR (QGIS 3.4) – Taras Nov 9 at 20:17

Based on this grasswiki-article setting the operating system environment variable GISBASE to the GRASS installation folder might fix the issue (e.g. C:\OSGeo4W\apps\grass\grass76).

QGIS 3.8 processing options still doesn't contain an option for the GRASS folder.

I refer to Windows operating system and QGIS 3.8 / GRASS 7.6.

  • nailed it on the head for me: no GRASS folder in processing options for QGIS 3.8. There are a few other GRASS-associated folders, but nothing that is distinctly GRASS. I'm using QGIS 3.8.1. With respect to Taras' suggestion that the OP did not launch "QGIS with GRASS", that is not an option for me currently on my machine and may not have been one for the OP either. I know I've had that option in the past, I don't know what I did differently when I installed QGIS on this new (for me) machine to miss it. Adding the new environment path worked for me it seems. – shea Oct 17 at 17:22
  • Fixed it for me! – foobarbecue Nov 9 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.