1

On Ubuntu 18.04, using packages provided by universe repos

  • QGIS 2.18.17+dfsg-1
  • SAGA 2.3.1+dfsg-3build7

When starting any SAGA algorithm, QGIS crashes with a "Segmentation fault" error message.

We also tried to install QGIS 3.4 from https://qgis.org/ubuntu-ltr with both SAGA 2.3.1 (same package as above) or SAGA 7.2.0 according to https://sourceforge.net/p/saga-gis/wiki/Compiling%20SAGA%20on%20Linux/ ... In both cases, QGIS can't find SAGA.

We also tried to specify the path to SAGA lib by editing /etc/ld.so.conf.d/saga.conf

/usr/local/lib/saga

It didn't help.

What is the setup to make QGIS work with SAGA on this OS ?

closed as off-topic by Erik, Jochen Schwarze, whyzar, BBG_GIS, csk Feb 28 at 21:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you tried packages from the ubuntugis-unstable ppa? – AndreJ Feb 27 at 10:06
  • No. This is for stable teaching env purpose. We're not using such 'unstable' usually. – samb Feb 27 at 10:27
  • In this case it works (at least for me). Saga 7.2.0 is not supported by QGIS. – AndreJ Feb 27 at 11:01
  • You mean both QGIS and SAGA installed from that unstable PPA? Is it considered to be stable for a classroom? Would it be safe to suggest that method to the students to install on their own laptops? – samb Feb 27 at 11:09
  • 2
    I just tested with QGIS 3.4.2 installed from qgis.org/ubuntu some time ago and SAGA 2.3.1 from the main ubuntu repo and don't get a crash either. So I'm not sure what's wrong on your side. – AndreJ Feb 27 at 15:37

Browse other questions tagged or ask your own question.