1

I have a huge ol' model that's built to copy a bunch of data from one GDB into a different GDB and then delete two of the feature classes. If I build the model from scratch, it'll run fine the first time, but then encounters an error every subsequent time. The only way around this error is to manually re-input the data to be deleted every time. After the first time the model is run, the next time it will technically run but it skips the delete feature class step, even if it's a precondition for other steps. If I open the step, there's a

"Error:   
"000732: <value>: Dataset <value> does not exist or is not supported."

notice next to the data input. The data DOES exist, and I can manually re-select it from the folder.

Does anyone have an idea what could be causing this issue? I need the entire model to run automatically without user input, so I need it to be able to run every time without re-inputting the data to be deleted.

I've tried turning off background processing, I've tried running the model with or without the edit window open.

EDIT: I decided to see if I could run literally just the delete as a simple, separate model and it has the same issue. I've boiled it down to just this: enter image description here

It will run but nothing will happen, with this message:

Executing (Delete Media Filter SMPs): Delete O:\GIS\ArcGIS_Pro\Planning\workspace.gdb\gswiMediaFilter #
Start Time: Thu Feb 28 16:42:20 2019
The process did not execute because the precondition is false.
Succeeded at Thu Feb 28 16:42:20 2019 (Elapsed Time: 0.00 seconds)
0

From the diagnosis, your first run marks the tool as run (it puts a shade behind the tool) and the subsequent preconditions returns false. I think you need to Validate Entire Model (the tick icon adjacent to Run button) before each run.

Or if you save your model in a toolbox and run it in the Run Mode (double click on the model in the Catalog that produces standard tool run interface, where you can input the tool parameters that you assigned), it should be OK.

  • I wish it were that simple. I know to validate the model before running it (hence no shadow in the example above), and I've tried running it from catalog rather than the edit window (which I mentioned above). Neither of these things help. Thanks though. – Shaleby Mar 1 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.