2

I am running Ubuntu 18.04 with the XFCE interface and QGIS v3.6. When I start QGIS the menu bar at the top of the window is missing, and I can't find any way to bring it back. I found some solutions online that suggest modifying the QGIS2.conf file, but I don't have one of those.

Do any of you have ideas how to solve this? The main reason I use QGIS is to save quick previews of images, which is no longer possible without the menu bar!

(edit) Rostranimin suggests launching from the command line with the no configuration option, I had actually already tried this (but neglected to mention it). Doing so still results in no menu bar. (edit2) To give more background info: I was previously using Ubuntu 14.04 on this machine and whatever the default version of QGIS was for that distro (2.4?), then my company upgraded me to 18.04 with QGIS 3.6. In 2.4 the menubar was visible, it hasn't been visible since the update. Unfortunately as this is a company-managed machine I don't have sudo access, so my options to change things are limited.

I have another machine (self-managed) that's running Mint 19 with QGIS 3.6, the menu bar appears fine there.

closed as off-topic by Erik, Jochen Schwarze, LaughU, csk, Andre Silva Mar 1 at 22:52

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that relate to the business of vendors and product teams, such as licensing, pricing, release dates, submission of bug reports and enhancement requests, etc, are off-topic here and should be directed instead to the official software support teams." – Erik, Jochen Schwarze, LaughU, csk, Andre Silva
If this question can be reworded to fit the rules in the help center, please edit the question.

  • You can certainly launch QGIS using the command line on Windows, with an option for no configuration. I've not done this on linux. See the 'tip' box on this page: docs.qgis.org/2.18/en/docs/user_manual/introduction/… (which specifies launching QGIS from the command line with the '--nocustomization' option specified). – Rostranimin Mar 1 at 10:57
  • I should have mentioned (and have now edited my post) that I had already tried that: No change. – os1 Mar 1 at 11:06
  • @os1 - Maybe try the following in the Python Console in case it is hidden: iface.mainWindow().findChildren(QMenuBar)[0].show() – Joseph Mar 1 at 11:21
  • Just guessing/troubleshooting now and may not help at all - but try F11 (toggle full screen mode) and ctrl+shift+tab (toggle map only). – Rostranimin Mar 1 at 11:22
  • On Joseph's comment - you need ctrl+alt+p to get the python console if you have no menu... – Rostranimin Mar 1 at 11:23

Browse other questions tagged or ask your own question.