1

I have a polygon shapefile in CRS EPSG:27700 British National Grid that is a boundary of a study area that I would like to load into the iTree Canopy online tool. https://canopy.itreetools.org/index.php

The tool uses Google Satellite as its basemapping so in QGIS I have saved the layer with CRS EPSG:3857 WGS84

But when I try to load it I receive the error 'Invalid projection format'

enter image description here

The pop-up help tells me that the shapefile must be 'reprojected to geographic coordinates'

enter image description here

I have looked at the help video which essentially describes what I have tried to do above using QGIS - ie. reproject the shapefile into WGS84.

I also tried based on another web search using the Vector > Geometry Tools > Export/Add Geometry Columns

Is there something obvious that I am not doing?

  • 3
    Maybe you have to reproject to the WGS84 long/lat coordinate system? The epsg code is 4326 (not 3857) – Micha Mar 2 at 11:20
  • Thanks, I hadn't registered there were different EPSG codes for WGS84. My shapefile now saved as EPSG4326 no longer gives me the 'Invalid projection format' error message. – Martin Hügi Mar 3 at 0:01
3

Perhaps the iTree site needs layers in the Long/Lat geographic coordinate system, EPSG code 4326 (not 3857). EPSG 4326 is geographic and based on WGS84, whereas 3857 is projected also based on WGS84.

WGS84 is a datum, not a projection. There are many (hundreds, maybe even thousands)) of projections based on the WGS84 datum. For example there's a whole set of UTM projections which are based on the WGS84 datum. Each with slightly different projection parmmeters. So it's not enough to day "WGS84 projection".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.