1

I have QGIS 3.4.5 32bits. I added to the canvas a shapefile which has no defined coordinate system, but QGIS correctly guesses is WGS84 and warns about it. However when I go to the properties of the layer (right click layer/properties/Source) the Geometry and Coordinate Reference System title indicates that the layer is in WGS84, which is not exactly true since I have not yet actively set the CRS. Is there a way QGIS gives the right information that not CRS is set for the layer? because it is not always the person who created the qgs project, the same person who is using it.

Screen capture layer properties -source

  • Can you show QGIS "guessing"? What I see with any shapefile with no .prj component is a dialog asking me to "Specify CRS for layer test". WGS84 is the default there, but I can choose any. So I have actively set the CRS. What are you seeing? – Spacedman Mar 3 at 17:47
  • You are right, it was not guessing, I had the option in Settings/Options/CRS for new layers/Use a default CRS/ WGS84. – nanunga Mar 3 at 20:52
1

I am very happy I just found out that the information that I was looking for is in the metadata option (Layer Properties/Metadata/Extent/Coordinate Reference System/Not Set). Thanks for the answers and comments.

enter image description here

  • The layer has effectively assigned a CRS for the project in which it is loaded. Which is essential for QGIS to render it. No layer will have the Extent metadata tag written (and does not mean that any layer has a CRS assigned), unless someone explicitly writes it. – Gabriel De Luca Mar 4 at 4:58
0

An already loaded layer can not have a non-associated CRS.

You can configure the global (not project) QGIS behaviour when a layer without CRS information is loaded, by choosing it in Global Projection Specification.

There you can configure that QGIS explicitly prompt for the CRS of the layer so that it is actively selected when loading it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.