2

I want to add only a few specific columns from the join table but there is no drop down list. When selecting manually I'm able to select only 1 column when trying more than 1 I'm not getting the desired results.

I have tried writing like

1] column1, column2

2] 'column1', 'column2'

3] "column1", "column2"

4] (column1), (column2)

5] (column1, column2)

But none of them works. Please help how I can add only few selected columns

PS: the drop down option is available in join attributes by field tool when I try to use it without the processing modeler

enter image description here

  • 1
    As workaround, you can join all columns then use "Refacture fields" on resulting layer to define what columns you want to keep. – Mat Mar 6 at 17:13
  • @Mat How can I use the refactor fields in the model builder? In the fields mapping box I cannot enter data till the time I have some layers loaded but before I run my model there is nothing on the canvas If you know how this can be done please help. Thanks! – Vaibhav Gupta Mar 7 at 15:22
  • 1
    Under fields maping use add field, for all desired fields fill in column names under source expression and fieldname. – Mat Mar 7 at 16:58
  • Thanks Mat by using the Refactor fields tool I was able to shed out the fields that weren't required – Vaibhav Gupta Mar 8 at 11:05
2

Separate field names with a colon, eg:

column1;column2

https://issues.qgis.org/issues/20005

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.