0

I have a student license of ArcGIS Desktop 10.6.1, working on Windows 10.

When I try to open ArcMap, the splash screen loads, but then the program never actually opens. It doesn't generate any crash report, it just closes (have checked many places for error reports).

Other ArcGIS programs work (i.e. ArcCatalog), but close instantly if I open the Python interpreter.

If I install Arc without Python, the program works and the Python terminal will open, but it doesn't actually work. I.e. even the most basic print statement does nothing. Otherwise, I get the splash screen and 'crash'.

I suspect that it has something to do with Arc trying to use the 64-bt python version instead of the 32-bt version, but the instructions I found were unclear and I'm not sure how to fix this.

Things I have tried in Arc:

  • Repairing Arc; modifying by removing and then adding Python again workaround 2, 3 3
  • Full uninstall/reinstall of Arc
  • Modifying registry (python) workaround 1
  • Modifying registry by deleting software>ESRI 4
  • Updated graphics card driver (have Intel UHD Graphics 620)
  • Deleted anything related under AppData\Roaming
  • Modified/deleted normal.mxt 4
  • Verified contents of .pth (didn't need any changes) 5
  • Checked environment variables 5

Other things I tried on my machine:

  • Verified all computer updates are installed and ran a tune-up
  • Updated graphics card driver (have Intel UHD Graphics 620) 6
  • Checked for any driver conflicts, found none 7

My User PATH:

enter image description here

My system PATH:

enter image description here

I also added: C:\Python27\ArcGIS10.6\python.exe

I've tried contacting ESRI support but because it is a student version, any request has to go through my prof (who is being unresponsive). I need both ArcMap and Python/ArcPy to work, and I can't remove Python 3.7 from my machine because I need it.

Update: if I rename my Python37 folder Arc starts working - it opens and the python window works. So clearly there's something directing ArcGIS to 3.7 instead of 2.7. It's not great to have to rename my Python37 directory every time I want to use Arc though - is there another way??

  • If you can't uninstall Python3.7, have you tried removing references to python37 from your user and system paths (and keep ONLY the ARC references to python 27)? Also check for PYTHONHOME and PYTHONPATH. Are these set and what to? Of course, if you don't have admin privileges to remove Python 3.7 you might also not be able to edit system environment variables (I'm guessing this is a student PC and not your own). – MappaGnosis Mar 4 at 17:12
  • @MappaGnosis sorry, I mean that I need Python 3.7 for other things. I have admin privileges, it's my own machine. – jyingling Mar 4 at 17:15
  • OK - you can still run it without it being in the path - you just need to be tell windows the path of the exe you want to run at the commandline (which is a pain but could get you around the issue you are having. You can set an environment variable to (say) PY37 and point that at Python37. I have been using QGIS for ages now but vaguely remember this issue when I was using ArcMap back in the day. I'm wracking my brains for my solution but I think it was along these lines. – MappaGnosis Mar 4 at 17:23
  • @MappaGnosis could you clarify? – jyingling Mar 4 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.