1

After a few attempts I've transferred my QGIS project successfully to Qfield. I'm using Google Satellite Hybrid as my basemap and need to use it at as high a resolution as possible offline.

I've tried saving the image as a raster layer (Geotiff) in QGIS using the map view as the extent (Export - Save As - Rendered Image - Geotiff - Create VRT: off - EPSG:3857 - Extent: Map View)

To which I get an error: Unsupported Data Source: not a supported raster data source. Tried various other combinations (changing data output, VRT option) but keep getting the same error.

I've also tried to create a basemap via QField Sync. I don't get an error message but when I open the project in Qfield the basemap is in the layer list but is not displaying.

I've also tried a georeferenced image saved from Google but the resolution was too low to be usable.

  • I have used Atlas in Projects-Layouts to export individual tiffs, then combining these to a raster geopackage and used in QField. My basemap source was a different WMS than Google. You need a coverage layer, for example create a fishnet of your AOI. – BERA Mar 5 at 12:38
  • Thanks for your reply and introducing me to Atlas. I was successfully exporting the tiffs (which were looking good) until it crashed, now I can't seem to recreate it. I am getting multiple tiffs all of the same image and not different images for each square in my grid. Say I have 3 layers - the satellite basemap, a polygon layer and an overlaying vector grid saved as a shape file. I want to use the grid and extract a satellite image for each square. Can you please explain the steps in a bit more detail? – Lisa B Mar 7 at 8:10
  • 1
    Just realized it's because "Controlled by Atlas" was not selected, because it was greyed out. Seems when I clicked between Item properties and Layout then back to Item properties it became active. After selecting that and exporting again under Atlas I am getting a separate image for each square. – Lisa B Mar 7 at 8:44
1

I ran into the same issue with QFieldSync: no error message, but the basemap was not displaying in QField.

Once I made sure that all of my layers were saved with the same CRS as my project CRS (set under Project > Properties), my basemap displayed.

Since most (all?) popular basemaps are using EPSG: 3857 (WGS 84/Pseudo-Mercator), I set my project CRS to this and re-projected all my layers to this as well. Then my basemap showed up properly in QField.

1

Another option is to use the Tiles XYZ plugin. You can export MBTiles at varied zoom level of your map canvas (view extent and visible layers), add the MBTiles to the QGIS project, and export them to QField.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.