0

I have added a vender option of code for autoWrap to my xml and it does not seem to be working. I have used multiple different pixel lengths to see if I could see the update but I have not been able to see any change as a yet. In my reading, I came across a statement that autoWraping needs to be enabled. as I went further down the rabbit hole I could not find any documentation on that. listed below is the screenshot of the polygon I am watching to see if the .xml changes take as well as a snippet of the code I am editing.

Screen Shot

         <sld:Rule>
        <ogc:Filter>
          <ogc:PropertyIsLike wildCard="*" singleChar="#" escapeChar="!">
            <ogc:PropertyName>building</ogc:PropertyName>
            <ogc:Literal>*</ogc:Literal>
          </ogc:PropertyIsLike>
        </ogc:Filter>
        <sld:MinScaleDenominator>0</sld:MinScaleDenominator>
        <sld:MaxScaleDenominator>3600</sld:MaxScaleDenominator>
        <sld:Name>Yes</sld:Name>
        <sld:Title>Building</sld:Title>
        <sld:PolygonSymbolizer>
          <sld:Fill>
            <sld:CssParameter name="fill">#d4d6e4</sld:CssParameter>
          </sld:Fill>
          <sld:Stroke>
            <sld:CssParameter name="stroke">#d4d6e4</sld:CssParameter>
            <sld:CssParameter name="stroke-width">0.5</sld:CssParameter>
            <sld:CssParameter name="stroke-linejoin">round</sld:CssParameter>
          </sld:Stroke>
        </sld:PolygonSymbolizer>
        <sld:TextSymbolizer>
          <sld:Label>
            <ogc:PropertyName>name</ogc:PropertyName>
          </sld:Label>
          <sld:Font>
            <sld:CssParameter name="font-size">12</sld:CssParameter>
            <sld:CssParameter name="font-family">Nimbus Sans L Regular Condensed</sld:CssParameter>
          </sld:Font>
          <sld:LabelPlacement>
            <sld:LinePlacement>
              <sld:PerpendicularOffset>0</sld:PerpendicularOffset>
            </sld:LinePlacement>
          </sld:LabelPlacement>
          <sld:Fill>
            <sld:CssParameter name="fill">#749dae</sld:CssParameter>
          </sld:Fill>
          <sld:VenderOption name="autoWrap">20</sld:VendorOption>
          <sld:VendorOption name="maxDisplacement">50</sld:VendorOption>
          <sld:VendorOption name="labelAllGroup">TRUE</sld:VendorOption>
          <sld:VendorOption name="removeOverlaps">TRUE</sld:VendorOption>
          <sld:VendorOption name="followLine">TRUE</sld:VendorOption>
          <sld:VendorOption name="group">TRUE</sld:VendorOption>
          <sld:Halo>
            <sld:Radius>
              <ogc:Literal>0.26</ogc:Literal>
            </sld:Radius>
            <sld:Fill>
              <sld:CssParameter name="fill">#bce6f4</sld:CssParameter>
            </sld:Fill>
          </sld:Halo>
        </sld:TextSymbolizer>
      </sld:Rule>
2

I moved it down in the list and now it works. very odd

   </sld:Fill>
          <sld:VendorOption name="maxDisplacement">50</sld:VendorOption>
          <sld:VendorOption name="labelAllGroup">TRUE</sld:VendorOption>
          <sld:VendorOption name="removeOverlaps">TRUE</sld:VendorOption>
          <sld:VendorOption name="followLine">TRUE</sld:VendorOption>
          <sld:VendorOption name="autoWrap">40</sld:VendorOption>
          <sld:VendorOption name="group">TRUE</sld:VendorOption>
          <sld:Halo>
            <sld:Radius>
              <ogc:Literal>0.26</ogc:Literal>
            </sld:Radius>
            <sld:Fill>
              <sld:CssParameter name="fill">#bce6f4</sld:CssParameter>
            </sld:Fill>
  • seems odd, if you can reproduce it on 2.14.x or 2.15.x please raise a bug – Ian Turton Mar 7 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.