1

Action: At first time when opening project on QGIS 3.4.5 and 3.6 versions needs credentials to connect to PostgreSQL DB.

Problem: But after that when connection is success with correct credentials the qgis repeatedly asks the same credentials again to connect to the same DB when the maps is zooming and moving and etc.

repeatedly shows this window

With QGIS 2.18, 3.4.0, 3.4.1 versions all works fine and don't asking repeatedly credentials after first correct time.

Maybe someone knows whats is wrong?

put on hold as off-topic by PolyGeo 2 days ago

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that relate to the business of vendors and product teams, such as licensing, pricing, release dates, submission of bug reports and enhancement requests, etc, are off-topic here and should be directed instead to the official software support teams." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

1

You need to store the password during PostgreSQL connection adding. Once you did it. QGIS should not ask you again for the password. However, for single password insert it sounds like a bug in QGIS but without proper investigation is hard to say. Multiple reasons can cause this behavior that you're connection is trying to refresh.

Password storing

  • 2
    If you think it's a bug, please report it on the proper site (GIS SE is not a bug reporting site). – csk Mar 7 at 16:59
  • Thank You, Vince, but that I had done before, but problem still was there. – gcalibris Mar 7 at 22:28
  • @gcalibris - I'm here because I'm having the same issue. Can you share the bug report you filed, so I can track its progress? – J. Taylor Apr 12 at 5:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.