1

In my model, I'm trying to color my polygon layer using an xml file through categorized render tool (under cartography toolset). However, when I run the model the output file has the attribute data but nothing is visible in the canvas.

In the same model, when I'm doing the same process for a line layer it gives me the color as specified in the xml file

Any idea how this can be solved? Please help me

PS: When I'm using the same xml file to color the polygon layer outside the processing modeler it is working perfectly fine

  • You need to figure out what the model is doing differently from when you apply the xml file to the polygon layer outside the model. Compare the layer properties and style settings between the two outputs, and look for differences. Without access to the polygon layer, the processing model and the xml file, there's no way for anyone else to help with this testing process. – csk Mar 7 '19 at 17:06
  • 1
    I don't have time to work on this right now, but I will edit the links into your question so everyone can see them without having to search through the comments. – csk Mar 7 '19 at 17:33
1

There was a slight error from my end whenever I was trying to run the model. It was with inputting the parameters.

Although the columns (both in polygon and line layers) using which I wanted to color code were of string type but

one was a simple text like auto_correct while the other had special characters as well like (auto correct 1) and I somehow missed the "" before and after the column name.

Thanks a lot everyone who tried to help me with this error

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.