0

I have a county where there is some LiDAR (1 meter) coverage. For the rest of the county I downloaded 10 meter DEM from USGS. Both rasters are in same projection and units. I resampled the 10 meter to one meter and Mosaic to New Raster to produce one seamless raster for the county.

Need to get Zonal Statistics for parcels, and it keeps missing some parcels, I read some suggestions are convert to tif and resample so small parcels don't get omitted. So trying multiple analysis and always get 999999 error. These include:

(From Catalog) Export Raster to Different Format: TIFF

Resample

Spatial Analyst: Slope

Spatial Analyst: Aspect

Should I try new mosaic? Seems to me like my merged raster is corrupt in some way but I don't know how to best fix it.

  • Have you got enough space on your C drive? (assuming Windows) Does your user profile have a quota set? Perhaps try changing your environment TEMP and TMP to a disc that has lots of space. Have you tried restarting Catalog? Each Esri instance has its own temporary storage, if one has become corrupt then a new instance should avert using the same temp. BTW you should resample the 1m to 10m not the other way around, you need to go with the least accurate cell size or produce two succinct datasets from the 1m and 10m rasters or you risk perpetuating significant errors. – Michael Stimson Mar 8 at 3:36
  • @MichaelStimson Thanks for the suggestions. I am down to 25 gigs on my C drive where I am working. Going to clean that up now. I will resample and merge again. It seems like resampling the 1m to 10m defeats the purpose of having good 1m resolution data, right? If I will lose that resolution I will work with the data sets individually. Also, how do I restart Catalog? Just quit and reopen or do I need to restart computer. – sparky Mar 8 at 3:40
  • 1
    Have you tried explicitly adding .tif to the output file when running each step? – Keagan Allan Mar 8 at 3:54
  • @KeaganAllan Yep I have tried that. It fails with 999999. – sparky Mar 8 at 3:56
  • Now getting the 999999 error with other datasets. Have a usgs 10m DEM, tried SA Slope, error 999999. I cleaned up my C drive (over 130 GB free), and have tried writing to my organization's DropBox as well. Same thing. I have checked all my Environment settings, they seem good. I am using a new .mxd with only this DEM added. Is there a way to reset all arcmap settings to default? Seems like something changed at some point but I can't pinpoint it. – sparky Mar 8 at 16:35
1

Found this answer from this article on Geonet: https://community.esri.com/thread/212358-error-999998-unexpected-error-in-most-106-spatial-analyst-tools.

This fixed the error.

Customize > ArcMap Options > Raster Dataset > Maximum number of unique values to render: I reduced this from 100,000,000 to 100,000.

  • 1
    You can accept your own answer with the checkbox – BERA Apr 29 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.