1

I use the following command in linux with an "&" hoping to be able to close that putty session but "&" doesn't seem to work with this command :

sudo mapproxy-util serve-develop mapproxy.yaml -b 0.0.0.0:8010

When I run the above command with an "&" I get the following output (instead of a MapProxy instance startup log) :

[1] 30354

When I then do a ps aux | grep 8010 it gives the following result:

root 30354 0.0 0.1 49252 3488 pts/0 T 15:23 0:00 sudo mapproxy-util serve-develop mapproxy.yaml -b 0.0.0.0:8010

And when I try to access MapProxy demo page it gives:

"This site can’t be reached"

  • 8010 seems to be the port your program is listening at. Do you connect at the correct port? Also you might want to consider using screen starting background processes – nickves Mar 12 at 14:42
  • Yes, that is the right port I am using, When I start a MapProxy Instance without "&" everything works as expected. Okay, Let me try with 'screen'.. – lakshmi Mar 12 at 14:45
  • Thankyou so much nickves, using 'screen' with the command worked! – lakshmi Mar 12 at 16:33
1

So the command which worked for me is the following:

screen -L sudo mapproxy-util serve-develop mapproxy.yaml -b 0.0.0.0:8010

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.