I've been having an issue with the SAGA functions for a while now, I believe since upgrading to one of the early 3.x versions. No matter which function I use they all fail with the same error (screenshot below). GRASS and GDAL functions work fine. The way our network is set up, I'm frequently wrestling with extremely long file paths, but I still get the error when testing with a copy on the desktop. In writing this up I have been able to get it to work after running Fix Geometries on some files but not on others, and that is the first time I've seen a SAGA function succeed in months. None of the files I'm working with are large, and I get the error regardless of apparent data quality of source. All the data I'm working with used to have no issue with the SAGA commands up until a few months ago.

enter image description here

I've been having this issue across various 3.x versions, using Windows 10 64bit. I've been using QGIS for ~2 years now and have not seen these issues up until maybe six months ago. I'm now using the 'QGIS 3.6.0 with GRASS 7.6.0' installed using the standalone installer. I've been running more attempts than I normally do as I try to gather info for this post, and am seeing intermittent success instead of consistent failure. Seeing that people have been running the commands fine, I wanted to try again and generate some better error logs for folks to look at. I opened an new untitled QGIS project in QGIS 3.6.0 with GRASS 7.6.0. Brought in a point file of address points, a polygon file of property parcels and a line file of roads. Ran a 10 ft buffer using SAGA on each of them. It failed twice in a row on the points, succeeded on the polygons and lines. I then tried running Thiessen polygons on the points, another command that has produced failures for me -- this was just to see if could get an error log from a different SAGA command, since I've been seeing it across multiple commands. The Thiessen polygons failed as well. It failed again after running QGIS 'Fix Geometries' command on the point file. I then opened QGIS 3.6.0 without GRASS, just to see, ran the same SAGA buffer command on the same point file and it succeeded(!). I then started a new project in QGIS 3.6.0 with GRASS 7.6.0, ran the same 10 ft SAGA buffer on the same point file and it also succeeded(!??). I then tried running SAGA thiessen polygons on the same point file and it failed again.

I saved most of the logs from these attempts and put them into Google drive: https://drive.google.com/drive/folders/1fOWhkdfXLYRDvh9OmjJzZlJ5K0XEaQNe?usp=sharing

  • Please make a bug report: issues.qgis.org – csk Mar 21 '19 at 20:59
  • @csk, OP has already opened a bug report: issues.qgis.org/issues/21620. But it seems that it is not an easy error to reproduce, and if the developers can not reproduce it they do not consider it a bug. In fact, it's probably not a bug. – Gabriel De Luca Mar 21 '19 at 22:59

I'm using the SAGA Fixed distance buffer processing tool on Windows 7 64 bit with QGIS 3.4.5 LTR and QGIS 3.7.0 Master (37faa0d883) without problems.

Perhaps you are using an earlier version of QGIS.

| improve this answer | |
  • Confirmed here, from a Windows 10 64bit machine, saga_cmd shape_tools "Shapes Buffer" command does not raise an error. Judging by the screenshot of the error, OP is using a stand-alone QGIS 3.6, probably on Windows 10. I wrote my answer from a Windows 7 32bit machine, OSGeo4W QGIS 3.6. Tomorrow I can check it again. – Gabriel De Luca Mar 20 '19 at 2:14

The problem is not the same for all tools, you need to copy the output log for each tool.

For the Fixed distance buffer tool, the problem is a bug in the QGIS algorithm.

The SAGA command is: saga_cmd shapes_tools 18 [-SHAPES <str>] [-BUFFER <str>] [-DIST_FIELD <str>] [-DIST_FIELD_DEFAULT <double>] [-DIST_SCALE <double>] [-DISSOLVE <str>] [-NZONES <num>] [-POLY_INNER <str>] [-DARC <double>]

and the algorithm is trying to execute: saga_cmd shapes_tools "Shapes Buffer" [-SHAPES <str>] [-BUFFER <str>] [-DIST_FIELD <str>] [-DIST_FIELD_DEFAULT <double>] [-DIST_SCALE <double>] [-DISSOLVE <str>] [-NZONES <num>] [-POLY_INNER <str>] [-DARC <double>]

The issue must be reported. A bug report was already opened by OP: https://issues.qgis.org/issues/21620.

At the time of writing my answer, I opened a random project, tried to run the tool and produced the error in the syntax. But I cannot longer reproduce it in 32bit or 64bit Windows machines, QGIS 3.4.5, 3.6.0 neither 3.7.0.

At this moment, it seems to me that it is best to attach the layers and the project that produce the error to the support ticket. Even the detail of the error log.

Once the feedback to the developers have been exhausted, you can request the reopening here to write the appropriate answer for future references.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.