1

I've made a simple model that takes a CSV of lat/longs with radio signal levels, makes an XY event layer, selects values over -120, then converts to raster. In the Make XY Event layer the spatial reference is set for GCS_NAD83 with datum D_NAD83, which corresponds to the source of the CSV files. When I run the model by itself it works correctly and returns a raster in NAD83, how ever in batch mode the first raster is returned correcly with NAD83, but all subsequent rasters are return with GCS_WGS_1984 and datum D_WGS_1984. I've checked the results posted below and they show that each layer is returned as NAD83 in the Make XY Event Layer but when I check the properties they are different. I even get a warning at the end of batch processing that they use Datum.
For your reference I've included the results for four files. In the Make XY Event Layer it shows they are all the same. I've also include screen shots of the properties so you can see that the results differ.

enter image description here

Messages

Executing: RAPTRascii2raster "C:\Users\Frank\Documents\ArcGIS\LAcounty Data\CWIRS\Basin Simulcast\CCTFinalCCTFinal.txt" C:\Users\Frank\Documents\ArcGIS\Default.gdb\neg120_CCT
Start Time: Fri Mar 15 09:48:59 2019
Executing (Make XY Event Layer): MakeXYEventLayer "C:\Users\Frank\Documents\ArcGIS\LAcounty Data\CWIRS\Basin Simulcast\CCTFinalCCTFinal.txt" longitude latitude CCTFinalCCTFinal_Layer "GEOGCS['GCS_NAD83',DATUM['D_NAD83',SPHEROID['GRS_1980',6378137.0,298.257222101]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]];-400 -400 11258999068426.2;-100000 10000;-100000 10000;8.98315284119521E-09;0.001;0.001;IsHighPrecision" level
Start Time: Fri Mar 15 09:49:00 2019
Executing (Make XY Event Layer): MakeXYEventLayer "C:\Users\Frank\Documents\ArcGIS\LAcounty Data\CWIRS\Basin Simulcast\MLUMountLukens.txt" longitude latitude MLUMountLukens_Layer "GEOGCS['GCS_NAD83',DATUM['D_NAD83',SPHEROID['GRS_1980',6378137.0,298.257222101]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]];-400 -400 11258999068426.2;-100000 10000;-100000 10000;8.98315284119521E-09;0.001;0.001;IsHighPrecision" level
Executing (Make XY Event Layer): MakeXYEventLayer "C:\Users\Frank\Documents\ArcGIS\LAcounty Data\CWIRS\Basin Simulcast\OATOatMountain.txt" longitude latitude OATOatMountain_Layer "GEOGCS['GCS_NAD83',DATUM['D_NAD83',SPHEROID['GRS_1980',6378137.0,298.257222101]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]];-400 -400 11258999068426.2;-100000 10000;-100000 10000;8.98315284119521E-09;0.001;0.001;IsHighPrecision" level
Executing (Make XY Event Layer): MakeXYEventLayer "C:\Users\Frank\Documents\ArcGIS\LAcounty Data\CWIRS\Basin Simulcast\VPK-150VerdugoPeak-150.txt" longitude latitude VPK-150VerdugoPeak-150_Layer "GEOGCS['GCS_NAD83',DATUM['D_NAD83',SPHEROID['GRS_1980',6378137.0,298.257222101]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]];-400 -400 11258999068426.2;-100000 10000;-100000 10000;8.98315284119521E-09;0.001;0.001;IsHighPrecision" level
Succeeded at Fri Mar 15 09:49:55 2019 (Elapsed Time: 54.55 seconds)
Executing (Select): Select CCTFinalCCTFinal_Layer C:\Users\Frank\Documents\ArcGIS\Default.gdb\JPKJohnstonePeak_Select ""level" >= (-120)"
Start Time: Fri Mar 15 09:49:55 2019
Executing (Select): Select MLUMountLukens_Layer C:\Users\Frank\Documents\ArcGIS\Default.gdb\JPKJohnstonePeak_Select ""level" >= (-120)"
Executing (Select): Select OATOatMountain_Layer C:\Users\Frank\Documents\ArcGIS\Default.gdb\JPKJohnstonePeak_Select ""level" >= (-120)"
Executing (Select): Select VPK-150VerdugoPeak-150_Layer C:\Users\Frank\Documents\ArcGIS\Default.gdb\JPKJohnstonePeak_Select ""level" >= (-120)"
Succeeded at Fri Mar 15 10:03:17 2019 (Elapsed Time: 13 minutes 22 seconds)
Executing (Point to Raster): PointToRaster C:\Users\Frank\Documents\ArcGIS\Default.gdb\JPKJohnstonePeak_Select level C:\Users\Frank\Documents\ArcGIS\Default.gdb\neg120_CCT MOST_FREQUENT NONE 0.00083333
Start Time: Fri Mar 15 10:03:17 2019
Executing (Point to Raster): PointToRaster C:\Users\Frank\Documents\ArcGIS\Default.gdb\JPKJohnstonePeak_Select level C:\Users\Frank\Documents\ArcGIS\Default.gdb\neg120_MLU MOST_FREQUENT NONE 0.00083333
Executing (Point to Raster): PointToRaster C:\Users\Frank\Documents\ArcGIS\Default.gdb\JPKJohnstonePeak_Select level C:\Users\Frank\Documents\ArcGIS\Default.gdb\neg120_OAT MOST_FREQUENT NONE 0.00083333
Executing (Point to Raster): PointToRaster C:\Users\Frank\Documents\ArcGIS\Default.gdb\JPKJohnstonePeak_Select level C:\Users\Frank\Documents\ArcGIS\Default.gdb\neg120_VPK MOST_FREQUENT NONE 0.00083333
Succeeded at Fri Mar 15 10:05:03 2019 (Elapsed Time: 1 minutes 45 seconds)
Succeeded at Fri Mar 15 10:05:04 2019 (Elapsed Time: 16 minutes 5 seconds)

enter image description here

  • If the coordinate system does not change, why not set at the model level the output coordinate system, this should be inherited by all tools in the model. Just go to model properties to set this. – Hornbydd Mar 15 at 18:00
  • Thanks. I'm pretty new to Modelbuilder not to mention Arcmap so wasn't aware of that option. Although I'm trying to consider how a model setting would work. It seems that when I turn the CSV to an XY layer, that I should be explicate? – Frank Mar 15 at 18:19
  • Anyways though, I think this is a problem I'd like to solve before I move on. I'd like to understand why the tool isn't working like I think it should. – Frank Mar 15 at 18:38
1

In "Make XY Event Layer" the coordinate system is an optional parameter and defaults to WGS84. Your model does not publish this optional parameter. It batch mode it must be this combination of not published and optional that makes the model use the default value (WGS84). Try publishing the coordinate system and making it a required parameter. Don't forget CSV has no coordinate system so you should always supply one.

  • I added a spatial reference parameter to the Make XY input and ran a batch job a couple of times. Now I'm having an issue where the output files are all the same, even though the results show three separate input files being used. When I run the tool individually I get the correct results though. Also inexplicably, I found that one of my outputs was the wrong coordinate system, even though the results show it as being the same as the others?? – Frank Mar 21 at 3:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.