I try to insert a WMS but Google Earth says WMS capability failed. This is the WMS: https://ccff02.minfin.fgov.be/geoservices/arcgis/services/WMS/Cadastral_Layers/MapServer/WMSServer

I know it is a 1.3.0 WMS server, could that be the issue?

  • Can you get layers from the pre-installed WMS servers? I could not when I just tried with Google Earth Pro (64-bit).
    – user30184
    Commented Mar 18, 2019 at 10:39
  • I get a 403 unauthorized request response
    – Ian Turton
    Commented Mar 18, 2019 at 11:09
  • In QGIS & AutoCAD the WMS works
    – Raymarcher
    Commented Mar 18, 2019 at 11:54
  • This is the full adress: ccff02.minfin.fgov.be/geoservices/arcgis/services/WMS/…
    – Raymarcher
    Commented Mar 18, 2019 at 11:56

2 Answers 2


Trying again following previous advice given in answer Linking Geoserver WMS layer to Google Earth?

With Google Earth Pro (using desktop version as I don't have/want Chrome) I too get the WMS Capability fetch failed message when trying to load your service, and it is indeed due to version, Google Earth sends a WMS version 1.1.1 GetCapabilities request and your service doesn't support it.

The reason as much as anything is that GE wants to use 2D WGS84 in long/lat order (which is what a WMS 1.1.1 GetMap request will give you if you request SRS=EPSG:4326&), however EPSG:4326 is actually a 2D WGS84 in lat/long order, the issue of using the correct axes order for coordinate reference systems was corrected with WMS version 1.3.0, but not so helpful for using GE.

To the rescue CRS:84, that is a WMS version 1.3.0 request that uses CRS=CRS:84& is equivalent to a WMS version 1.1.1 request that uses SRS=EPSG:4326&.

Luckily, as GE retains as a connection string for a layer a list of parameters except the bounding box like below:


all you need to do is get GE to accept a layer connection string like

http://ccff02.minfin.fgov.be/geoservices/arcgis/services/WMS/Cadastral_Layers/MapServer/WmsServer?VERSION=1.3.0&REQUEST=GetMap&SERVICE=WMS&FORMAT=image/png&width=1024&height=1024&STYLES=&TRANSPARENT=TRUE&CRS=CRS:84&LAYERS=Regional building

One way of doing this is to use KML like:

                http://ccff02.minfin.fgov.be/geoservices/arcgis/services/WMS/Cadastral_Layers/MapServer/WmsServer?VERSION=1.3.0&amp;REQUEST=GetMap&amp;SERVICE=WMS&amp;FORMAT=image/png&amp;width=1024&amp;height=1024&amp;STYLES=&amp;TRANSPARENT=TRUE&amp;CRS=CRS:84&amp;LAYERS=Province </href>

To give:

Google Earth Pro with KML from WMS 1.3.0 only service

  • You are the hero of the day, worthy of your reputation. I already tried to reverse engineer the link layer connection but with limited knowledge no succes. So the root of the problem is that there is no 1.1.1 version of the WMS? If that gets added then it is probably good to go. Thanks a lot.
    – Raymarcher
    Commented Mar 22, 2019 at 16:11

This may be more of an extended comment than answer but, Google Earth is correct in identifying that the WMS 1.3.0 service is giving an invalid response.

For example, the name of the service cannot be <Name>CadastralLayers</Name> for a WMS 1.3.0 response it must be <Name>WMS</Name>

Also the MinScaleDenominator and MaxScaleDenominator in all the layers are in the wrong order, that is the service has:


but it needs to be:

  • Thanks for the pointers, so the name must be literaly "WMS"?
    – Raymarcher
    Commented Mar 21, 2019 at 8:57
  • @Raymarcher yes, see the schema schemas.opengis.net/wms/1.3.0/capabilities_1_3_0.xsd ~ <element name="Name"><simpleType><restriction base="string"><enumeration value="WMS"/>...
    – nmtoken
    Commented Mar 21, 2019 at 9:48
  • Both issues are resolved but still Google Earth cannot load the layers :-/, I suspect there are still orher issues.
    – Raymarcher
    Commented Mar 21, 2019 at 15:04
  • Is GE still saying that capability failed?
    – nmtoken
    Commented Mar 21, 2019 at 15:11
  • Yes, it still says "WMS Capability fetch failed".
    – Raymarcher
    Commented Mar 21, 2019 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.